1

I had Ubuntu 18 before and I reinstalled Ubunto 20.04 on / partition. I didn't change /home partition during the installation process. I set the same username and. password I had before.

When I try to login to Ubuntu I choose my account, type a password. I see a black screen and I see the log in page again without any error message or something. I googled it and it looks like "login loop error".

On the login screen, I switched to the console mode ([Alt] + [Ctrl] + [F3]) and successfully logged in.

I executed ls -la in my home directory and I see only few items:

Access-Your-Private-Data.desktop -> /usr/share/ecryptfs-utils/encryptfs-mount-provate.desktop
.encryptfs -> /home/.encryptfs/szymon/.encryptfs
.Private -> /home/.encryptfs/szymon/.Private
README.txt -> /usr/share/encryptfs-utils/mount-private.txt

I think the problem here is the lack of mounted encrypted /home partition. Is that a correct statement?

How to fix that?

6
  • Did you encrypt /home during install of 18.04 or after install?
    – crip659
    Jul 26, 2020 at 13:15
  • I don't remember but during installation (I think)
    – Simon
    Jul 26, 2020 at 13:28
  • Think that might be the problem. 20.04 was not made aware of encrypted partition. 20.04 was new install, not upgraded? This is as far as I can help. Will need better people to help from now.
    – crip659
    Jul 26, 2020 at 13:35
  • This link might give some help, but be careful. askubuntu.com/questions/699056/…
    – crip659
    Jul 26, 2020 at 13:49
  • Yes, 20.04 was a new install
    – Simon
    Jul 26, 2020 at 13:51

1 Answer 1

1

Ok, I solved the issue :)

I've logged in to the system in a console hidden behind [Ctrl] + [Alt] + [F3]. Next I updated system and installed cryptsetup and ecryptfs-mount-private.

Next, I ran ecryptfs-mount-private command, provided a password to the encrypted /home partition and that's all.

After rebooting the partition was already mounted.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.