8

I installed Ubuntu 20.04 from the official website and installed terminator using APT and It worked! Ctrl+Alt+T started terminator.

Then I installed cinnamon desktop, rebooted and Ctrl+Alt+T came up with the default terminal, not with terminator.

I changed the priority to higher than the default emulator with sudo update-alternatives --install /usr/bin/x-terminal-emulator x-terminal-emulator /usr/bin/terminator 60, this also didn't work.

sudo update-alternatives --config x-terminal-emulator gives this table:

Selection    Path                             Priority   Status
------------------------------------------------------------
* 0            /usr/bin/terminator               60        auto mode
  1            /usr/bin/gnome-terminal.wrapper   40        manual mode
  2            /usr/bin/terminator               60        manual mode

What am I doing wrong? Is cinnamon interfering here?

1
  • I haven't used Cinnamon for years, so I am not sure of the exact workflow, but you should be able to remove the default Ctrl+Alt+T shortcut and then add a new Ctrl+Alt+T shortcut which will run terminator. Another option could be completely uninstalling gnome-terminal. Jul 25, 2020 at 18:07

2 Answers 2

9

Please enter the following in a terminal :

gsettings set org.gnome.desktop.default-applications.terminal exec /usr/bin/terminator

gsettings set org.gnome.desktop.default-applications.terminal exec-arg "-x"

You might have to enter the following line as well

gsettings set org.cinnamon.desktop.default-applications.terminal exec /usr/bin/terminator
0

Changing the bin file to the one you want for the keyboard shortcut works for me.

Go to: Keyboard -> Application Shortcuts

Then change the command tab for terminal to -> /usr/bin/terminator Or whatever the path to your binary program. Peace out.

Keyboard menu

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .