4

I have upgraded from Ubuntu 18.04 to 20.04. One application does not run any more with the error:

error while loading shared libraries: libssl.so.1.0.0: cannot open shared object file: No such file or directory

I have searched this forum and followed the advice and tried: sudo apt-get install libssl1.0.0:amd64.

I get:

Package libssl1.0.0 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'libssl1.0.0' has no installation candidate

I also tried sudo apt install libssl1.1, and I get:

libssl1.1 is already the newest version (1.1.1f-1ubuntu2).
libssl1.1 set to manually installed.
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 openmpi-bin : Depends: libopenmpi3 (>= 4.0.3) but it is not going to be installed
               Recommends: libopenmpi-dev but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

So then I tried sudo apt --fix-broken install libssl1.1, but I get:

libssl1.1 is already the newest version (1.1.1f-1ubuntu2).
libssl1.1 set to manually installed.
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 openmpi-bin : Depends: libopenmpi3 (>= 4.0.3) but it is not going to be installed
               Recommends: libopenmpi-dev but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

I also tried 'E: Unable to locate package libssl1.0' and I get:

E: Unable to locate package libssl1.0

Finally I tried:

sudo apt install --fix-broken
sudo apt-get update
sudo apt-get upgrade

However, I still get the same error. Any ideas before I downgrade to Ubuntu 18.04?

  • Did you enable the repository from which you installed openmpi packages? On OS upgrade process this repo has been disabled as it is third party repository (I think). – mariaczi Jul 24 '20 at 9:08
  • 1
    apt-file search libssl.so.1.0.0 finds it in the nsight-compute and nsight-systems packages. – ajgringo619 Jul 24 '20 at 14:37
6

I ran into the same issue I think (I had the same error message trying to launch RStudio after upgrading Ubuntu from 18.04 to 20.04). Here is what worked for me after reading the following page: https://packages.ubuntu.com/xenial/amd64/libssl1.0.0/download

  • Edit the source list sudo nano /etc/apt/sources.list to add the following line: deb http://security.ubuntu.com/ubuntu xenial-security main
  • Then sudo apt update and sudo apt install libssl1.0.0.

I hope t works for you too.

  • 1
    Perfect. thank you! – Paulo E. Cardoso Sep 20 '20 at 0:10
  • 1
    Is it a good advice to suggest installing xenial packages into 20.04? You might end up with a totally broken system all at once in the future, may you? Sounds as extremely dirty advice. I will not try to damage my own 20.04.x installation with this advice. – Eugene Gr. Philippov Dec 13 '20 at 13:10
  • Offtopic: Hmm I hope most or all Linuxes will adopt nix in the future as it solves all kinds of similar problems. – Eugene Gr. Philippov Dec 13 '20 at 13:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.