19

I have upgraded from Ubuntu 18.04 to 20.04. One application does not run any more with the error:

error while loading shared libraries: libssl.so.1.0.0: cannot open shared object file: No such file or directory

I have searched this forum and followed the advice and tried: sudo apt-get install libssl1.0.0:amd64.

I get:

Package libssl1.0.0 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'libssl1.0.0' has no installation candidate

I also tried sudo apt install libssl1.1, and I get:

libssl1.1 is already the newest version (1.1.1f-1ubuntu2).
libssl1.1 set to manually installed.
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 openmpi-bin : Depends: libopenmpi3 (>= 4.0.3) but it is not going to be installed
               Recommends: libopenmpi-dev but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

So then I tried sudo apt --fix-broken install libssl1.1, but I get:

libssl1.1 is already the newest version (1.1.1f-1ubuntu2).
libssl1.1 set to manually installed.
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 openmpi-bin : Depends: libopenmpi3 (>= 4.0.3) but it is not going to be installed
               Recommends: libopenmpi-dev but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

I also tried 'E: Unable to locate package libssl1.0' and I get:

E: Unable to locate package libssl1.0

Finally I tried:

sudo apt install --fix-broken
sudo apt-get update
sudo apt-get upgrade

However, I still get the same error. Any ideas before I downgrade to Ubuntu 18.04?

2
  • Did you enable the repository from which you installed openmpi packages? On OS upgrade process this repo has been disabled as it is third party repository (I think).
    – mariaczi
    Commented Jul 24, 2020 at 9:08
  • 1
    apt-file search libssl.so.1.0.0 finds it in the nsight-compute and nsight-systems packages. Commented Jul 24, 2020 at 14:37

8 Answers 8

42

I ran into the same issue I think (I had the same error message trying to launch RStudio after upgrading Ubuntu from 18.04 to 20.04). Here is what worked for me after reading the following page: https://packages.ubuntu.com/xenial/amd64/libssl1.0.0/download

  • Edit the source list sudo nano /etc/apt/sources.list to add the following line: deb http://security.ubuntu.com/ubuntu xenial-security main
  • Then sudo apt update and sudo apt install libssl1.0.0.

I hope t works for you too.

7
  • 4
    Perfect. thank you! Commented Sep 20, 2020 at 0:10
  • 11
    Is it a good advice to suggest installing xenial packages into 20.04? You might end up with a totally broken system all at once in the future, may you? Sounds as extremely dirty advice. I will not try to damage my own 20.04.x installation with this advice. Commented Dec 13, 2020 at 13:10
  • Offtopic: Hmm I hope most or all Linuxes will adopt nix in the future as it solves all kinds of similar problems. Commented Dec 13, 2020 at 13:15
  • you are my hero! Commented May 3, 2021 at 20:51
  • 2
    This failed for me with E: The repository 'http://security.ubuntu.com/ubuntu xenial-security InRelease' is not signed. N: Updating from such a repository can't be done securely, and is therefore disabled by default..
    – ijt
    Commented Feb 23, 2022 at 17:39
14

I solved my problem with libssl1.0.0 like this:

I opened http://security.ubuntu.com/ubuntu/pool/main/o/openssl1.0/ in my browser and download last version of libssl1.0.0 for my system (for me it was libssl1.0.0_1.0.2n-1ubuntu5.6_amd64.deb) Then I just install it:

sudo gdebi ./libssl1.0.0_1.0.2n-1ubuntu5.6_amd64.deb
8
  • 1
    Cheers for this, but doesn't work for me! I get the following error message: This package is uninstallable Dependency is not satisfiable: libssl1.0.0 (= 1.0.2n-1ubuntu5.6) Commented Apr 28, 2021 at 2:29
  • Hm... I have Ubuntu 20.04, it was ok. What dependencies does it want?
    – Verter
    Commented Apr 28, 2021 at 11:13
  • 2
    Apparently the solution was to download manually via wget and then install with dpkg. Commented Jul 23, 2021 at 12:50
  • 4
    Thank you for your help. Just do clarify for others: wget http://security.ubuntu.com/ubuntu/pool/main/o/openssl1.0/libssl1.0.0_1.0.2n-1ubuntu5.7_amd64.deb and then dpkg -i libssl1.0.0_1.0.2n-1ubuntu5.7_amd64.deb this did the trick for me on Ubuntu 20.04
    – Daywalker
    Commented Sep 20, 2021 at 13:13
  • But not for me.Today(09/2022) the only solution listed here for 20.04 is to use the link above (security.ubuntu.com/ubuntu/pool/main/o/openssl1.0/)and manually install libssl1.0.0_1.0.2n-1ubuntu5.10_amd64.deb all others solution seem out to date.
    – Xzu
    Commented Sep 13, 2022 at 20:12
6

I had this problem too. RStudio depends on libssl 1.0.0, while Ubuntu 20.04 distributes the newer libssl 1.1.0.

Here is how to download and install the older version manually:

wget http://security.ubuntu.com/ubuntu/pool/main/o/openssl1.0/libssl1.0.0_1.0.2n-1ubuntu5.6_amd64.deb
sudo dpkg -i *.deb

Hopefully, RStudio will at some point be upgraded to work with the newer version of libssl.

1
  • 1
    Please don't suggest to install *.deb. If there are other .deb files in the directory where the wget downloaded it will attempt to run them as sudo. Please me careful and prescriptive with fully qualified names. Commented May 6, 2022 at 20:11
4

I was trying to install RStudio Server 1.4.1103 on Ubuntu 20.04 and had the "libssl1.0.0 problem" (Ubuntu 18.04+ uses libssl1.1 natively). I found the solution here and made some version updates. Check here for updates.

Installing libssl1.0.0

$ wget http://security.ubuntu.com/ubuntu/pool/main/o/openssl1.0/libssl1.0.0_1.0.2n-1ubuntu5.13_amd64.deb
$ sudo apt install ./libssl1.0.0_1.0.2n-1ubuntu5.13_amd64.deb

Installing RStudio Server 1.4.1103

$ sudo apt-get install gdebi-core
$ wget https://download2.rstudio.org/server/bionic/amd64/rstudio-server-1.4.1103-amd64.deb
$ sudo gdebi rstudio-server-1.4.1103-amd64.deb

Finding my local IP (in my case 192.168.0.17)

ip addr show

Finally I opened Studio Server in my browser using http://192.168.0.17:8787/.

2
  • file not found on server
    – brauliobo
    Commented Nov 1, 2023 at 19:31
  • @brauliobo, take a look at the updated link.
    – zabala
    Commented Nov 3, 2023 at 9:23
1

I needed the lib for eagle7.7

My solution:

cd /lib/x86_64-linux-gnu
sudo ln -s libssl.so.1.1 libssl.so.1.0.0
sudo ln -s libcrypto.so.1.1 libcrypto.so.1.0.
0

I use Debian Buster when I faced the issue like you. I resolved it by doing this:

First I see libssl1.0.0 is not in the Debian Buster APT Repository, it is replace by libssl1.1

Therefore, I add the Jessie APT repository to /etc/apt/source.list by run this command:

sudo nano /etc/apt/source.list

Paste the Jessie APT Repository: "deb http://security.debian.org/debian-security jessie/updates main"

Save and Exit (Ctrl + s && Ctrl + x) Run the update: sudo apt update Install the libssl1.0.0 package sudo apt install libssl1.0.0

Re-run rstudio, and it will run successfully.

2
  • 1
    Adding a repository of a different distribution is a very bad practice: not only this solution may not work (Packages are distribution dependent), it may also cause a handful of dependencies installation and overall unpredictable results.
    – Pizza
    Commented Mar 4, 2021 at 10:47
  • 1
    This is the same as askubuntu.com/a/1264351/158442 but for Debian, and answers here must apply to Ubuntu
    – muru
    Commented 12 hours ago
-1

Hit this link and download "libssl.so.1.0.0" file manually:

https://packages.debian.org/search?suite=jessie&arch=any&mode=exactfilename&searchon=contents&keywords=libssl.so.1.0.0

2
  • 1
    no results found
    – brauliobo
    Commented Nov 1, 2023 at 19:30
  • While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. - From Review
    – David
    Commented 7 hours ago
-1

I was installing an incompatible version of the package. I double-checked for the new version and worked.

The software was Rstudio-server https://posit.co/download/rstudio-server/

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .