40

Ubuntu 20.04 LTS by default has the date and time show on the top of the desktop.

How can I include the weekday (examples: Sunday, Monday, ect)?

I want the day of the week show with the date and time how do i do this?

date I am referencing is shown in top center of screen shot. enter image description here

5

4 Answers 4

95

To show the weekday in addition to the date and time in Ubuntu 20.04, use the command line tool called "gsettings".

It's a good idea to view your current settings first. So open the terminal and run this command:

gsettings list-recursively org.gnome.desktop.interface

It will return various Gnome interface settings, and the one you are interested in is "clock-show-weekday" (with the value "false").

Set the "clock-show-weekday" to "true" by running this command:

gsettings set org.gnome.desktop.interface clock-show-weekday true

Once you hit Enter, you will will see the weekday displayed with the weekdays shown.

7
  • 2
    For some reason, this didn't work for me; the settings were changed, but the display still did not show the weekday. Using dconf-editor did the trick though, as explained in this link. Oct 27, 2020 at 22:01
  • @fabio_hirono Indeed, this answer didn't work for me.
    – MWB
    Feb 24, 2021 at 19:44
  • This worked instantly for me on Ubuntu 20.04.3 LTS. Sorry, not sure why it didn't work for either of you.
    – mwfearnley
    Dec 28, 2021 at 20:24
  • This seems to have no effect on Ubuntu 22.04 Nov 24, 2022 at 14:06
  • Worked instantly for me on Pop!_OS 22.04. Jan 5, 2023 at 17:09
9

You can try this in the terminal.

gsettings set org.gnome.desktop.interface clock-show-date true
gsettings set org.gnome.desktop.interface clock-show-seconds true
gsettings set org.gnome.desktop.interface clock-show-weekday true
5

Install GNOME Tweaks like this:

sudo apt install gnome-tweaks

After installing it open the app named "Tweaks", find menu item named "Top Bar" and then enable weekday:

Screenshot

GNOME Tweaks is a wonderful tool that should be installed after installing synaptic but before installing anything else.

0

To add on to the other excellent answers, it's possible to get the following error/warning while changing org.gnome.desktop.interface settings:

GLib-GIO-Message: Using the 'memory' GSettings backend.  Your settings will not be saved or shared with other applications.

the issue was discussed here and the general answer is that environment variable GIO_EXTRA_MODULES need to point to the location of gio modules like so:

export GIO_EXTRA_MODULES=/usr/lib/x86_64-linux-gnu/gio/modules/

To make the above permanent, this needs to be put in .bashrc

After doing so, org.gnome.desktop.interface will be saved.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .