0

so I am new to how to do these, so I apologize if something I say is not how things are done here.

So I have been using Ubuntu 18.04 for a while now. Recently I wanted to try and dual boot LineageOS to just play around with it, and I think I may have damaged my Grub files (or whatever it is called). I have tried to force boot the partition with Ubuntu on it, but I keep getting the same error.

Grub rescue> ls
(hd0) (hd0,msdos1) (hd1) (hd1,msdos1)
grub rescue>set boot=(hd0,msdos1)
grub rescue>set prefix=(hd0,msdos1)/boot/grub
insmod normal
error:unknown filesystem.

I tried the same thing with set root=(hd0,msdos1) but that got me the same issue. I tried both of these variants with (hd0), (hd1), (hd1,msdos1), and got again the same errors. I am unsure of what to do at this point because I have gone through a lot of different things to try and fix this issue and none of them have done anything. Any advice or suggestions are welcome, and I appreciate all of it!

Note: I did try to boot off of a live USB, which gives me a blank screen, and if I try to boot it through Grub rescue ((hd1,msdos1) is its file system) and I get the same error through Grub. If there are any questions at all feel free to ask, and thank you in advance.

8
  • what do you mean "i did try to boot off of a live USB, which gives me a blank screen"? what was involved in those steps? – WU-TANG Jul 21 '20 at 23:35
  • Unknown filesystem usually is the wrong partition... First ensure which partition you want to boot from ls (hd0,0)/ ls (hd0,1)/ ls (hd1,0)/home/ etc..etc... until you've located the correct one (you can just use the number).... Also take a look at what returns from just typing 'set' – WU-TANG Jul 22 '20 at 0:03
  • @WU-TANG: First Comment: I went to the bios setting, and changed the boot order to boot my USB first so that it automatically would try and boot my USB key. In that process, I get a menu that asks if I would like to try Ubuntu without installing, install ubuntu, or check the disk for malfunctions (Or it was something along these lines). If I clicked any of the options, it would have a splash screen of some numbers in the corner, and then go to a black screen, where there is no response. Please let me know if there is any more info I can give. – TheBlinded Jul 22 '20 at 5:28
  • @WU-TANG: Second Comment: I will try your first suggestion when I have the time (It is late as I am writing this, so it will have to wait till the morning) but as for the command "set" output, I get this: cmdpath=(hd0) prefix=(lvmid/h1gqcw-ntj0-gciK-2Doa-XdKn-YMQa-4DG2FV/OBg9xz-gk30-aMsG-SNOc-SLFS-HBTQ-LTsxzj)/boot/grub root=lvmid/h1gqcw-ntj0-gciK-2Doa-XdKn-YMQa-4DG2FV/OBg9xz-gk30-aMsG-SNOc-SLFS-HBTQ-LTsxzj I am not sure what any of this means, but when entering grub rescue, I get error: disk 'the same strand as prefix and root here' not found. Entering rescue mode... – TheBlinded Jul 22 '20 at 5:35
  • @WU-TANG: I just want to also thank you for your response. I have been trying to fix this issue for a few days now, and have just taken it as a learning opportunity rather than fix a broken PC, so any advice or suggestions you have given me are greatly appreciated! So thank you again! – TheBlinded Jul 22 '20 at 5:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.