I cannot go pass the black screen and the following shows up on my screen after upgrading and rebooting with the Ubuntu update manager from 11.10 to 12.04:

ata_id [27]: HDIO_GET_IDENTITY failed for '/dev/sdb/': Invalid argument

*stopping save kernel messages

Setting up X font server socket directory /tmp/.font-unix...done.

Starting X font server:xfs.

Rather than invoking init scripts through /etc/init.d, use the service(8) utility, e.g. service S25 bluetooth start inid: Unkown job: S25 bluetooth

Since the script you are attempting to invoke has been converted to an upstart job, you may also use the start(8) utility, e.g. start S25bluetooth

*PulseAudio configured for per-user sessions

Saned disabled; edit /etc/default/saned

*Checking battery state... [OK]

After this nothing happens anymore.

I even tried booting from different linux versions and also from recovery mode. I've tried repairing the packages and even updating the grub loader.

*I have Ubuntu in an external hard drive but there were never any problems with booting before the upgrade.

*Also, it seems to be something to do with invoking init scripts rather than other problems. (If u think it isn't, still do try to help me solve the problem.)

Please help!

  • maybe it's because of your video card driver. check this thread: askubuntu.com/questions/68220/… – JonSlowCN Apr 27 '12 at 14:58
  • I have read about certain video card drivers causing problems but it doesn't seem to be the case for me. The problem seems to be about: 1. my hard drive. 2. a certain script. But if u know how to solve the driver problem (in recovery mode?) please still do teach me. I'll try it. Thanks a lot!! – Aaron Chung Apr 27 '12 at 15:07

Press CTRL+ALT+F1 and reinstall your graphic card drivers from the command line.

If you're using NVidia, it's most likely sudo apt-get purge nvidia-current and sudo apt-get install nvidia-current.
After that, run sudo reboot.

  • 1
    @RobinJ You are right, my bad, I just assumed from the comment :) Thanks for pointing it out. I will give it a +1 though. – Mark Kirby Jan 6 '16 at 14:19

You could try booting from Grub with the option:


This should boot ubuntu in failsafe graphics mode. If you have a proprietary driver you can then fix it under additional drivers. If this isn't the case, you could try reinstalling xorg and its drivers:

sudo apt-get remove --purge xserver-xorg
sudo apt-get install xserver-xorg
sudo dpkg-reconfigure xserver-xorg
  • After xforcevesa I couldn't 1.See my cursor. 2. I can't select the options as it seems that the keyboard stops responding once I get into failsafe graphical mode. Meaning that I can't select the options and So I can't say I could offficial get failsafe graphical mode to work. and for reinstalling xorg, it seems that some of my software clash with them and even after I removed the software I still couldn't reinstall xorg. Please try to help! – Aaron Chung Apr 28 '12 at 2:58
  • You may have to resort to a fresh install. They are usually less problematic and better for drivers etc. – Joshun Jun 10 '12 at 12:15

It does look like a video driver issue that is causing plymouth and lightdm to fail to start. However, I think you'll find the machine has booted and is operational, albeit in text-only mode - try switching to the first console by holding down the CONTROL, ALT and F1 keys. Hopefully, you'll find a login screen to allow you to access the system.

Also, try booting by removing "splash" and "quiet" from the kernel command line by editing the grub menu entry. This may give more information. I would also recommend looking at /var/log/Xorg.0.log and the log files in /var/log/lightdm/ and /var/log/syslog which may give an indication as to what is going on.

  • Ctrl Alt and F1 has indeed allowed me to access the system but I still can't solve the problem. Removing "splash" and "quiet" ended up showng the same message. Also, I don't know how to look at the logs from the command line, and I don't know how to let u see the log. Please do help! – Aaron Chung Apr 28 '12 at 2:52
  • Use the 'less' command to view files from the command line like this: less /var/log/Xorg.0.log To move to the next page, press the space bar. To exit less, type 'q' (quit). For help (there are lots of commands in less) type 'h'. To leave the help screen, type 'q'. – jamesodhunt May 1 '12 at 16:15
  • To look for errors in your X server log, do this: grep '(EE)' /var/log/Xorg.0.log – jamesodhunt May 1 '12 at 16:18
  • thx I'll try that as soon as I have time as I have exam now – Aaron Chung May 2 '12 at 13:06

I had the same problem. It seemed to be an issue with broken dependencies.

You can fix broken dependencies like this:

sudo apt-get -f install

In my case apt-get had a problem parsing the /var/lib/dpkg/status and /var/lib/dpkg/available files due to blank lines in the description entries for a mind mapping program called Xmind.

I deleted these blank lines, re-ran

sudo apt-get -f install

and everything was ok.

Hope it helps.


I tried many options and many different installs mentioned here and there. Nothing seemed to help. Interestingly, when I installed server 12.04, the problem manifested on the first reboot. When I installed desktop 12.04, it only happened after initial software updates were applied. This was all 64 bit.

I ended up taking a simple way out. This machine was older for mainly file service, so I just replaced the video card and all was well. However, it appeared that it hangs at a grub selection screen. Pressing enter to start the loading seemed to kick things off. I don't know if it would have booted at some point without enter or not.

So, you might just press enter as it might be on a screen that can't be seen correctly. Or, try another video card. I wish I would have thought of the latter 4 days ago.

Not the answer you're looking for? Browse other questions tagged or ask your own question.