4

I have installed WSL and WSL2 and I am trying to print a document from Ubuntu WSL. But unfortunately, I can't install the driver for the printer. I'm getting these errors:

[description of error][]

In WSL, I have installed Ubuntu 20.04 and trying to install hplip-3.20.3.run but I'm getting

another description

When I am even trying to install python-pyqt5, the message says it's already installed. I don't know what to do. Does it mean that we cannot print in WSL?

4
  • On normal Ubuntu the simple sudo apt-get install hplip-gui would be enough, not sure about WSL.
    – N0rbert
    Jul 20 '20 at 16:11
  • Do you have cups installed?
    – Brian Z
    Jul 20 '20 at 17:56
  • 1
    Hi all. @BrianZ, yes I have it installed but it was not working. I worked around cups and finally it's working. I am preparing all the steps to post it here how i manage to get cups working. The filter in cups was throwing an error and cups did not install all the necessary files. Jul 22 '20 at 10:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.