0

This page https://developer.download.nvidia.cn/compute/cuda/repos/ubuntu1804/x86_64/ list lots of drivers.

I need to install the version nvidia-driver-440_440.33.01-0ubuntu1_amd64.deb because my dmesg is saying:

NVRM: API mismatch: the client has the version 440.33, but
NVRM: this kernel module has the version 440.100.  Please
NVRM: make sure that this kernel module and all NVIDIA driver
NVRM: components have the same version.

after I run

docker run --gpus all nvidia/cuda:10.0-base nvidia-smi

So I need the specific version 440.33

I tried downloading and installing:

sudo apt install -y ./nvidia-driver-440_440.33.01-0ubuntu1_amd64.deb 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'nvidia-driver-440' instead of './nvidia-driver-440_440.33.01-0ubuntu1_amd64.deb'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 nvidia-driver-440 : Depends: libnvidia-gl-440 (= 440.33.01-0ubuntu1) but 440.100-0ubuntu0.20.04.1 is to be installed
                     Depends: nvidia-dkms-440 (= 440.33.01-0ubuntu1)
                     Depends: nvidia-kernel-source-440 (= 440.33.01-0ubuntu1) but it is not going to be installed
                     Depends: libnvidia-compute-440 (= 440.33.01-0ubuntu1) but 440.100-0ubuntu0.20.04.1 is to be installed
                     Depends: nvidia-compute-utils-440 (= 440.33.01-0ubuntu1) but it is not going to be installed
                     Depends: libnvidia-decode-440 (= 440.33.01-0ubuntu1) but 440.100-0ubuntu0.20.04.1 is to be installed
                     Depends: libnvidia-encode-440 (= 440.33.01-0ubuntu1) but 440.100-0ubuntu0.20.04.1 is to be installed
                     Depends: nvidia-utils-440 (= 440.33.01-0ubuntu1) but it is not going to be installed
                     Depends: xserver-xorg-video-nvidia-440 (= 440.33.01-0ubuntu1) but 440.100-0ubuntu0.20.04.1 is to be installed
                     Depends: libnvidia-cfg1-440 (= 440.33.01-0ubuntu1) but 440.100-0ubuntu0.20.04.1 is to be installed
                     Depends: libnvidia-ifr1-440 (= 440.33.01-0ubuntu1) but 440.100-0ubuntu0.20.04.1 is to be installed
                     Depends: libnvidia-fbc1-440 (= 440.33.01-0ubuntu1) but 440.100-0ubuntu0.20.04.1 is to be installed
                     Recommends: nvidia-settings but it is not going to be installed
                     Recommends: nvidia-prime (>= 0.8) but it is not going to be installed
                     Recommends: libnvidia-compute-440:i386 (= 440.33.01-0ubuntu1)
                     Recommends: libnvidia-decode-440:i386 (= 440.33.01-0ubuntu1)
                     Recommends: libnvidia-encode-440:i386 (= 440.33.01-0ubuntu1)
                     Recommends: libnvidia-ifr1-440:i386 (= 440.33.01-0ubuntu1)
                     Recommends: libnvidia-fbc1-440:i386 (= 440.33.01-0ubuntu1)
                     Recommends: libnvidia-gl-440:i386 (= 440.33.01-0ubuntu1)
E: Unable to correct problems, you have held broken packages.
1
  • Maybe this answer will help you resolve dependencies. – Aaryan BHAGAT Jul 18 '20 at 7:32
0

It looks like installing package manually will cause dependency issues and You might endup in breaking dependency tree.

I would suggest you to use official nvidia ubuntu ppa. It will install necessary dependencies automatically.

 sudo add-apt-repository ppa:graphics-drivers/ppa -y 

 sudo apt update -y 

 sudo apt install nvidia-driver-440 -y 

If you are using docker image for your application,You can re-build docker image with particular version to align with driver version. You can add above commands in docker file and build docker image.

3
  • The problem is that it'll install 440.100, but my program uses some cuda driver that uses 440.35.01 – Lucas Zanella Jul 18 '20 at 6:29
  • Please edit your question and add full details what original issue you have. – KK Patel Jul 18 '20 at 6:31
  • edited!............ – Lucas Zanella Jul 18 '20 at 6:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.