I selected security updates and other updates in update manager and I clicked 'install updates'. It showed up an error like so 'Requires to install untrusted updates' and I clicked 'close', and it was the only button visible. The update manager started to build the list of updates again and it showed up 'install updates' button once again. Same thing happened again and again and I was not able to install any updates.


In the software centre go to edit and software sources (type in your password) one of your software sources in the other sources tab does not have a key.

This does not necessarily mean it is bad but that you would need a key

Check this url:


This will help you to resolve the error.

| improve this answer | |
  • The linked page doesn't exist any more. Could you update it with something else? – Arkya Chatterjee Feb 9 '18 at 19:04

Apparently this was an issue two years ago (2011) and is again an issue (2013). I am running Ubuntu 13.04 and the update manager will not update because of an 'untrusted update' error. The actual error message says something like "This update will require installation from untrusted sources" and the buttons available are 'settings' and 'ok'.

Normally if someone warns you and you say, "Ok" the action takes place. Not so here. "Ok" simply closes the update manager. 'settings' opens the settings dialogue window, with no particular indication of how to fix the problem.

I checked out the liberiangeek site mentioned by aneeshep, ran the sudo command recommended there, and the update command ran fine, did not find any missing public keys. I then ran the Ubuntu Software Updater, and it still found 81.3 MB of downloads, and the list looks to be the same: some security updates, some other updates, and a long list of Ubuntu base updates.

When I click on "Install Now" and type in my password, the updater downloads a number of packages, installed them, and told me "The software on this computer is up to date"

YAY! Finally! (It also mentions an upgrade to 13.10 is available...)

So: relevant instructions are:

From a terminal (Applications>>system>>XTerm) type

              sudo apt-get update

After this command finishes, close the terminal with "exit". Next, try updating your system, it should work.

| improve this answer | |

You can install Muon package manager and use it instead of the update manger, its great to install it write on you terminal:

  1. apt-get install muon
| improve this answer | |
  • This does not answer the question. Recommending other package managers is not a real answer. – Marco Ceppi Dec 10 '11 at 21:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.