24

So I did a fresh install of Ubuntu 20.04 on a computer with the new RTL8125B Realtek network card and I cannot get the network to work.

I was very suprised since this is supposed to be the new feature of the 5.4 kernel (I have 5.4.0-26-generic installed).

Does anyone have any idea on how to get it working? Thank you.

$ lspci -knn | grep Eth -A3
06:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8125 2.5GbE Controller [10ec:8125] (rev 04)
Subsystem: ASUSTeK Computer Inc. RTL8125 2.5GbE Controller [1043:87d7]
Kernel modules: r8169
07:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] [1002:67df] (rev e7)

$ dmesg | grep -i r8169
[    0.911236] r8169 0000:06:00.0: unknown chip XID 641
10
  • Please edit your question and add output of lspci -knn | grep Eth terminal command.
    – Pilot6
    Jul 17 '20 at 20:00
  • @Pilot6 I added the output. In the meantime I tried: realtek.com/en/component/zoo/category/… to no avail Jul 19 '20 at 22:18
  • I made a typo, please post the output of lspci -knn | grep Eth -A3
    – Pilot6
    Jul 19 '20 at 22:20
  • done :) Thank you for the help. Jul 19 '20 at 22:27
  • Now please add output of dmesg | grep -i r8169
    – Pilot6
    Jul 19 '20 at 22:31
28

I had the same exact issue. Looks like you're missing drivers for the Ethernet.

Go to this link (which is from the actual Ethernet provider): https://www.realtek.com/en/component/zoo/category/network-interface-controllers-10-100-1000m-gigabit-ethernet-pci-express-software

Download the "2.5G Ethernet LINUX driver r8125 for kernel up to 5.6" and follow the installation instructions.

You should be able to use wired connection once you're done.

9
  • 1
    I tried that (see the second comment under the main question), but until I had internet connection working on the computer, I couldn't install the necessary packages for the instalation/compilation... since the fresh install of Ubuntu does not come with even the build-essentials... Aug 12 '20 at 12:26
  • 1
    The above solution fixed my broken Ethernet LAN. Instructions are in the README file of the download from the link provided above by MrGoldWatch. I have a fresh install of ubuntu 20.04.1 on a new PC build with Gigabyte B550 Aorus Master with Realtek 8125B 2.5G Ethernet. Instructions are short and worked immediately, but I had to first install make using sudo apt-get install build-essential using a wifi connection. Aug 17 '20 at 3:15
  • This worked for me on a Proxmox 6.2-1 distribution running on an ASRock Z490M-ITX/ac motherboard. Check the README file in the driver and run the autorun.sh script, then add the interface in /etc/network/interfaces. For me the new interface name was enp3s0. Linux proxmox 5.4.65-1-pve #1 SMP PVE 5.4.65-1 (Mon, 21 Sep 2020 15:40:22 +0200) x86_64 GNU/Linux Oct 22 '20 at 16:01
  • Worked for me on an MSI Z490 motherboard. If you do not see the ethX as described in the README, try the good old reboot method. :)
    – Py_Dream
    Dec 20 '20 at 12:42
  • same here on ubuntu 20.04. but ubuntu got upset At main.c:160: - SSL error:02001002:system library:fopen:No such file or directory: ../crypto/bio/bss_file.c:69 - SSL error:2006D080:BIO routines:BIO_new_file:no such file: ../crypto/bio/bss_file.c:76 sign-file: certs/signing_key.pem: No such file or directory Feb 1 at 21:56
19

The rtl8125b support has been added to the linux-next tree 6 days ago.

https://git.kernel.org/pub/scm/linux/kernel/git/next/linux-next.git/commit/drivers/net/ethernet/realtek?h=next-20200720&id=0439297be95111cf9ef5ece2091af16d140ce2ef

It will take some time to get into stable and then into Ubuntu.

You can try to install drivers from the Realtek site before Linux supports it natively. You'll need to disable Secure Boot in BIOS and blacklist r8169 to get them working.

The issue is fixed in the 5.9 kernel. Unfortunately Ubuntu 20.10 and 20.04.2 won't have this kernel. So a mainline kernel, or a backport is needed.

13
  • I did install the 5.8.0 kernel from mainline ubuntu but the card is still not working.
    – amarkovits
    Aug 6 '20 at 8:45
  • 1
    It hasn't been added to 5.8. It should appear in 5.9.
    – Pilot6
    Aug 6 '20 at 8:50
  • 2
    This is a way of running. It would be useful if you write an answer about which drivers you installed and how.
    – Pilot6
    Aug 6 '20 at 19:59
  • 2
    After installing r8125, from time to time my PC automatically upgrades the driver to r8169, making internet inaccessible again, do you guys know how to disable this specific upgrade?
    – Negrito
    Sep 14 '20 at 0:05
  • 1
    You understood this wrong. After a kernel upgrade the r8125 should be rebuilt against the new kernel. To avoid this you need to install it using dkms.
    – Pilot6
    Sep 14 '20 at 7:17
8

There are no installation instructions on the realtek download page.

Anyways this solution worked for me:

Here's a solution I found;

    Go to the Realtek website 387

    Download the Unix(Linux) r8125 driver. You will need to give an email address.
    1754×445

    Go to /Downloads directory. Extract the Tarball.

    In Terminal, go into r8125-xxxx folder and run the autorun.sh

    $ sudo ./autorun.sh

Everything should run automatically and you should get ethernet connection now.
5
  • I do not understand why they have not added support for network adapters for the Asus TUF 550 motherboard. This issue has happened to me a few times with this motherboard and Ubuntu 20.04 over various updates. Feb 27 at 19:17
  • Worked for me under Debian 10 (MB is MSI MAG B460M MORTAR WIFI). No additional packages were required it seems.
    – grinderX19
    Mar 8 at 15:43
  • Thank you very much @user2904033. It worked for me.
    – Delosari
    Mar 20 at 21:39
  • 1
    Might be worth noting that you need some dependencies to install at, at least make. In doubt I installed build-essential.
    – Didier L
    Mar 30 at 22:09
  • Thank you so much! I've tried alot of solutions and this one worked for me! Worked on Ubuntu 20.04
    – John
    Apr 2 at 4:47
1

The problem happens with me on kernel 5.4 now with kernel 5.10 there is no problem.

Not the answer you're looking for? Browse other questions tagged or ask your own question.