I am trying to migrate a virtual machine I use for my classes at the university from 10.04 to 12.04 and in that I am using xulrunner so that

  • first, I can have SQLiteManager as a stand alone app
  • next, KNIME can provide help for its nodes

I tried adding the the mozilla ppa as described in some posts, e.g. here or here, but when I search for xulrunner in Synaptic I get no match.

I read in this link, that xulrunner was left out intentionally, which, frankly, I think is a bad decision! Anyway, does anyone know a way out of this, i.e. how to get xulrunner?

  • 3
    Please take a moment to look at the answers to your question, and to upvote and/or accept the best answer which solves your problem (use tick/check mark on the left). This way, the question is marked as "answered" and future readers can refer to it knowing the solution works. Thank you!
    – ish
    Commented Jul 11, 2012 at 19:57
  • 1
    Note that xulrunner is now deprecated: ftp.mozilla.org/pub/xulrunner/nightly/latest-mozilla-aurora/… ; XULRunner future and ownership - Google Groups
    – sdaau
    Commented Nov 18, 2015 at 19:38
  • Hello! It appears as though this questions has not yet been marked as solved. If one of the answers fixed your problem, please take the time to hit the grey checkmark by the answer. This will mark it as "solved" and make it easier for others to find. Plus, it'll give you some reputation!
    – Kaz Wolfe
    Commented Jan 18, 2017 at 0:06

5 Answers 5


xulrunner is no longer available in the repositories for 12.04, but it's very easy to install the latest versions provided by the Mozilla Foundation here. Since these xulrunner releases are self-contained, we'll put them in the /opt directory.

  1. Open the terminal with Ctrl+Alt+T
  2. Type cd /opt
  3. The below steps will automatically download the appropriate version of xulrunner based on the currently installed version of Firefox and whether your Ubuntu is 32-bit or 64-bit. (If you are running a Firefox beta, etc., please copy the URL manually from your browser and set XURL= to it (see below)

    • Copy and paste in the terminal, line by line:
    FFVER=`grep -Po  "\d{2}\.\d+" /usr/lib/firefox/platform.ini`
    ARCH=`uname -p`
    cd /opt
    sudo sh -c "wget -O- $XURL | tar -xj"
    sudo ln -s /opt/xulrunner/xulrunner /usr/bin/xulrunner
    sudo ln -s /opt/xulrunner/xpcshell /usr/bin/xpcshell

xulrunner is now installed, and can be run with simply xulrunner from anywhere.

  • To uninstall it, simply remove the xulrunner directory under /opt, and the /usr/bin/xulrunner and /usr/bin/xpcshell symbolic links.

I had similar issue with Eclipse failing. I was able to get my version of Eclipse working, by doing the following. You can do this for your intended applications.

  1. To find the version of XULRunner supported for your Eclipse version: http://www.eclipse.org/swt/faq.php#browserlinux
  2. Go to Mozilla XULRunner releases downloads. Choose the version you want. Ignore b* suffixed versions (beta), and try to opt for latest. Again, its your choice to go for required version.

    [DIR]   10.0.1/         09-Feb-2012 01:11   -    
    [DIR]   10.0.2/         16-Feb-2012 02:55   -    
    [DIR]   10.0.4esr/      22-May-2012 20:56   -    
    [DIR]   10.0/           29-Jan-2012 11:32   -    
    [DIR]   10.0b2/         28-Dec-2011 10:38   -    
    [DIR]   10.0b3/         08-Jan-2012 03:02   -    
    [DIR]   10.0b5/         18-Jan-2012 15:27   -    
    [DIR]   10.0b6/         24-Jan-2012 03:53   -

    I am installing 10.0.2 in this example.

  3. Choose the download based on your OS.

    I am running 32bit Linux so I go for xulrunner-10.0.2.en-US.linux-i686.tar.bz2

  4. Save the downloaded file, extract/install it.

    sudo tar -xjvf xulrunner-10.0.2.en-US.linux-i686.tar.bz2
  5. Set the path of xulrunner in the application file (eclipse.ini).

    -Dorg.eclipse.swt.browser.XULRunnerPath=/Path_where_xulrunner_is extracted/xulrunner/

Now Eclipse will use the given version of xulrunner installed.


You might want to take a look at this thread to see if the solution that worked for conkeror would work for you as well: http://www.mozdev.org/pipermail/conkeror/2011-October/002666.html


You can find a description of this problem in the KNIME FAQ. Basically, just install the binaries from the KNIME Update Site and voila; things should be properly formatted again.

  • Can you give a link of where to look?
    – nanofarad
    Commented Nov 5, 2012 at 13:41

Try installing the firefox-dev package. I think that package should provide the libs xulrunner had previously. I'm not sure about runtime libs but it sure does contain the libs required for compiling XUL apps that were previously shipped with XULRunner

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .