2

On 18.4.enter image description here

After doing sudo apt-get update && sudo apt upgrade -y what I do pretty much on a daily basis when the system informs me of new updates this happened.

enter image description here

After this I could not boot into the system, it would hang at that stage and continue to show the same message with gradually increasing numbers as seen in the image above.

I then booted into recovery mode.

enter image description here

There I chose to run the dpkg option, I think it was checking for packages to be removed or for bad packages.

Then this came up. Asking me to update and possibly remove packages. I opted yes for all choices.

enter image description here

After that I could still only boot into the full system after booting into recovery mode first, exiting that and then entering the full boot to the sysem from the recovery menu option.

Once in the system I ran Timeshift with a backup from the day before. Timeshift saved the system. Super happy I have that running and do daily backups. After the restore to before the update I could boot into the full system just like before. Since then I have not touched updates.

What should I do about this? Wait longer for more updates or try and debug the error I got?

edit: 2020-07-18 01 Waited a few days and did an update again. Similar error persists. Here is what I can see with more details.

After the update I see this. enter image description here

Again it hangs at this stage and just keeps posting the same error again and again. Only pressing the on/off button will be able to exit this process.

I then boot into recovery mode and execute dpkg there. Then I see this. Perhaps the error lies here? Not sure what all this means.. enter image description here

dpkg then removes some packages. enter image description here

enter image description here

These are the 4 packages dpkg removes. enter image description here

I let it finish this, then try to do a normal boot and it hangs at the above message again.

Again, did a restore with Timeshift to an OS image before the latest update and can boot into the system just fine. So yeah, if anyone has an idea, thank you for any pointers.

edit 2020-07-18 02:

sudo apt update
Get:1 file:/var/opt/amdgpu-pro-local ./ InRelease
Ign:1 file:/var/opt/amdgpu-pro-local ./ InRelease
Get:2 file:/var/opt/amdgpu-pro-local ./ Release [816 B]
Get:2 file:/var/opt/amdgpu-pro-local ./ Release [816 B]
Get:3 file:/var/opt/amdgpu-pro-local ./ Release.gpg                                         
Ign:3 file:/var/opt/amdgpu-pro-local ./ Release.gpg                                         
Hit:4 http://linux.teamviewer.com/deb stable InRelease                                      
Hit:5 http://ch.archive.ubuntu.com/ubuntu bionic InRelease                                  
Hit:6 http://ppa.launchpad.net/obsproject/obs-studio/ubuntu bionic InRelease                
Hit:7 http://ch.archive.ubuntu.com/ubuntu bionic-updates InRelease                          
Hit:8 http://dl.google.com/linux/chrome/deb stable InRelease                                
Hit:9 http://security.ubuntu.com/ubuntu bionic-security InRelease                           
Hit:10 http://ch.archive.ubuntu.com/ubuntu bionic-backports InRelease                       
Hit:11 https://download.docker.com/linux/ubuntu bionic InRelease                            
Hit:12 https://deb.nodesource.com/node_11.x bionic InRelease                                
Hit:13 https://packages.microsoft.com/repos/ms-teams stable InRelease                       
Hit:14 https://packages.microsoft.com/repos/vscode stable InRelease                         
Hit:15 https://packagecloud.io/slacktechnologies/slack/debian jessie InRelease            
Reading package lists... Done 
Building dependency tree       
Reading state information... Done
16 packages can be upgraded. Run 'apt list --upgradable' to see them.

sudo apt list -u
Listing... Done
code/stable 1.47.1-1594686231 amd64 [upgradable from: 1.47.0-1594283939]
google-chrome-stable/stable 84.0.4147.89-1 amd64 [upgradable from: 83.0.4103.116-1]
libegl-mesa0/bionic-updates 20.0.8-0ubuntu1~18.04.1 amd64 [upgradable from: 19.2.8-0ubuntu0~18.04.3]
libegl1-mesa/bionic-updates 20.0.8-0ubuntu1~18.04.1 amd64 [upgradable from: 19.2.8-0ubuntu0~18.04.3]
libgbm1/bionic-updates 20.0.8-0ubuntu1~18.04.1 amd64 [upgradable from: 19.2.8-0ubuntu0~18.04.3]
libgl1-mesa-dri/bionic-updates 20.0.8-0ubuntu1~18.04.1 amd64 [upgradable from: 19.2.8-0ubuntu0~18.04.3]
libgl1-mesa-glx/bionic-updates 20.0.8-0ubuntu1~18.04.1 amd64 [upgradable from: 19.2.8-0ubuntu0~18.04.3]
libglapi-mesa/bionic-updates 20.0.8-0ubuntu1~18.04.1 amd64 [upgradable from: 19.2.8-0ubuntu0~18.04.3]
libglx-mesa0/bionic-updates 20.0.8-0ubuntu1~18.04.1 amd64 [upgradable from: 19.2.8-0ubuntu0~18.04.3]
libldap-2.4-2/bionic-updates 2.4.45+dfsg-1ubuntu1.6 amd64 [upgradable from: 2.4.45+dfsg-1ubuntu1.5]
libldap-common/bionic-updates,bionic-updates 2.4.45+dfsg-1ubuntu1.6 all [upgradable from: 2.4.45+dfsg-1ubuntu1.5]
libwayland-egl1-mesa/bionic-updates 20.0.8-0ubuntu1~18.04.1 amd64 [upgradable from: 19.2.8-0ubuntu0~18.04.3]
libxatracker2/bionic-updates 20.0.8-0ubuntu1~18.04.1 amd64 [upgradable from: 19.2.8-0ubuntu0~18.04.3]
mesa-va-drivers/bionic-updates 20.0.8-0ubuntu1~18.04.1 amd64 [upgradable from: 19.2.8-0ubuntu0~18.04.3]
mesa-vdpau-drivers/bionic-updates 20.0.8-0ubuntu1~18.04.1 amd64 [upgradable from: 19.2.8-0ubuntu0~18.04.3]

I also found out that when booting with kernel

Linux version 4.15.0-109-generic (buildd@lgw01-amd64-010) (gcc version 7.5.0 (Ubuntu 7.5.0-3ubuntu1~18.04)) #110-Ubuntu SMP Tue Jun 23 02:39:32 UTC 2020

the problem is gone. But this means in the Grub menu that comes up I need to always select Advanced options and then an earlier kernel. This is possibly not the solution to this, is it?

edit 2020-07-18 03

sudo lshw -class display
  *-display                 
       description: VGA compatible controller
       product: UHD Graphics 620
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 07
       width: 64 bits
       clock: 33MHz
       capabilities: pciexpress msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:131 memory:f1000000-f1ffffff memory:d0000000-dfffffff ioport:e000(size=64) memory:c0000-dffff
  *-display
       description: Display controller
       product: Lexa PRO [Radeon RX 550/550X]
       vendor: Advanced Micro Devices, Inc. [AMD/ATI]
       physical id: 0
       bus info: pci@0000:02:00.0
       version: c0
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi bus_master cap_list rom
       configuration: driver=amdgpu latency=0
       resources: irq:139 memory:e0000000-efffffff memory:f0000000-f01fffff ioport:d000(size=256) memory:f2400000-f243ffff memory:f2440000-f245ffff

edit 2020-07-19

Installed the LTSE stack. Now when I boot I see this. enter image description here

6
  • Can you list the packages that are being upgraded? For example, doing a sudo apt update and then apt list -u in a terminal? This won't actually upgrade them. Post the results as text please, I can't read what is in some of your pictures. – Organic Marble Jul 18 '20 at 12:02
  • 1
    @OrganicMarble added the results, thx. – lowtechsun Jul 18 '20 at 14:54
  • Thanks for the update. Looks like video driver updates mostly which certainly can cause trouble. I don't know what "code" is though. What kind of video card does your computer have? – Organic Marble Jul 18 '20 at 14:58
  • It also looks like you are on 18.04 but did not do the HWE update wiki.ubuntu.com/Kernel/LTSEnablementStack which would give you a newer kernel series. Probably do not want to introduce another variable at this point but something to consider. – Organic Marble Jul 18 '20 at 15:01
  • @OrganicMarble code is for VS Code. Yeah the LTSE Stack was mentioned in Kubuntu IRC, though perhaps I can sort this with a better driver for the graphics card? What driver should I get for the card that I have given the added output? I got the drivers from the AMD page. – lowtechsun Jul 18 '20 at 17:49
0

The amdgpu drivers are not compatible with the latest version of the kernel. So I uninstalled them and then made sure to have the open source graphics drivers installed that come with the system by default.

https://amdgpu-install.readthedocs.io/en/latest/install-installing.html#uninstalling-the-amdgpu-graphics-stack

Uninstall AMD graphics drivers.

# Use this for All-Open components
amdgpu-uninstall

# Use this for Pro components
amdgpu-pro-uninstall

https://linuxconfig.org/how-to-install-the-latest-amd-radeon-drivers-on-ubuntu-18-04-bionic-beaver-linux

Install open source graphics drivers.

If you're running Ubuntu 18.04, you already have the open source AMD drivers installed. They're integrated into Mesa and the Linux kernel. Since, Ubuntu 18.04 is new, it'll have some of the latest features. However, if you want the absolute latest as long as you're running your system, there's an excellent PPA that packages Git versions of Mesa.

sudo add-apt-repository ppa:oibaf/graphics-drivers
sudo apt-get update
sudo apt update && sudo apt -y upgrade

With this in place I can enjoy a full boot into the system with latest kernel and latest update without any errors.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.