2

I bought a new empty HP ProBook 450 G7 laptop without any operating system. I entered into BIOS and made sure that USB Storage Boot checkmark has been set under the Advanced tab in the Boot Options section:

enter image description here

enter image description here

I also successfully created bootable USB drives with Rufus from the Ubuntu 20.04 desktop amd64 iso, but when I start my laptop I sequentially see the following screens:

Booting FreeDOS...

enter image description here

Boot menu and Automatic boot of FreeDOS:

enter image description here

Load FreeDOS including HIMEM XMS-memory driver:

enter image description here

In the end I get such a screen with just C:\> in the top left corner of a blank black screen.

enter image description here

but when I'm booting from USB drive I expect to see a screen with a choice of an Install Ubuntu action.

What's wrong with the settings of my BIOS? What could be the root cause of this problem? What should I look for?

2
  • What's your secure boot configuration? Also, have you tried using a CD/DVD instead? Which one(s)? For example I didn't succeed booting the desktop image on any of my UEFI boxes, but it works fine on legacy BIOS ones (and it worked fine with 18.04 before). I ended up installing from the server installation media which I was able to boot, although it came with its own issues (limitations of how many disks it will show during partitioning step). Molding your server installation into a desktop one is trivial: apt install ubuntu-desktop (or {k,l,x}ubuntu-desktop) ... – 0xC0000022L Jul 16 '20 at 20:13
  • 1
    Akeos answer is almost certainly the issue here. OP, I suggest not using Rufus to flash the ISO - it gives so many choices for advanced users that it can be confusing. I suggest using balena etcher. It's basically impossible to make a mistake since you only have two choices: source ISO and destination drive. balena.io/etcher – Nmath Jul 16 '20 at 22:07
3

Looks like you inadvertently selected FreeDOS in Rufus in the Boot selection menu.

Make sure Boot selection is set to your Ubuntu image, not FreeDOS when you create the drive.

7
  • It's pretty clear this is what happened. FreeDOS doesn't spawn from thin air. Until Rufus has an "easy mode", this is why I suggest that new Ubuntu users use Etcher – Nmath Jul 16 '20 at 22:11
  • 1
    FreeDOS spawns from having a very prominent dropdown saying FreeDOS when you press the big START button. You do realize that what some people prefer Rufus over Etcher because it allows you to create DOS drives or has other features, not proposed by Etcher that they find useful (with quite a few of those actually already hidden behind sections that aren't displayed by default, or through cheat modes, so as not to confuse users). At any rate, choice between applications that have a different vision with regards to the bare minimum proficiency its user should have is usually a good thing. – Akeo Jul 17 '20 at 1:16
  • For a lot of Ubuntu users, and visitors here, the most "advanced" and difficult task they ever do is to create valid installation media and install the operating system. I like Rufus, and I personally use it; it's an invaluable multi-tool and essential for some tasks. But for the purposes of AskUbuntu, when the audience is users who are having trouble installing an operating system, Rufus's options are overwhelming and can be confusing. I recommend etcher for this audience, which all-but eliminates the potential for user error. Etcher is also multi-platform, and not Windows-only. – Nmath Jul 17 '20 at 1:49
  • Etcher needs to be installed, you can start Rufus by just double clicking the downloaded .exe file. If a beginner uses default settings in Rufus, they can't go wrong. – C.S.Cameron Jul 17 '20 at 4:19
  • 1
    And here once again, people are falling into the exact trap that people joke about StackOverflow/SuperUser, whereas, whenever somebody asks "I am using X to do Y, and I am encountering issue Z", the "answer", instead of trying to resolve issue Z devolves into "You shouldn't be using X!". This is plaguing this site so much that it has become a meme at this stage, and you do understand that people who come to this because they have the same issue and want to find an explanation for it won't care much about an "OP should have been using A instead of X!" discussion. – Akeo Jul 17 '20 at 11:23
0

Did you make sure that your boot order shows USB as first boot option? Or possibly that the USB option is enabled for the USB slot you are using? If not, correct these, then power off the computer, insert USB drive that has Ubuntu ISO image on it, then power on machine.

0
  1. Go into the Secure Boot Configuration and make sure that Secure Boot is disabled.
  2. If you are not sure how to do this, please post a picture of the Secure Boot Configuration menu.
  3. Then make sure that USB (possibly USB HDD) is at the top of the boot order.
  4. You might also try with UEFI Boot Order unchecked.
0

I don't think you should check "USB STORAGE BOOT", I think you should be able to install from USB without that? I believe on that bios (HPs), that option uses LEGACY mode... which is fine... but you'd have to make sure you disable secure boot and there may be another legacy/CSM enable or checkbox somewhere in the menus that you have to turn on...

I would start with:
secure boot disabled
uncheck usb storage boot
set the usb as the first boot option
(this is going to do a UEFI install...boot screen should be black vs purple)
it may have a different verbiage than "first boot option" maybe "hard drive order" or "boot sources"... you have to arrange them in the proper order of precedence.

You could also, at boot, hit the esc key repeatedly until the startup menu comes up... then hit f9 to go straight to the boot menu. Then you should see all the devices you can boot from.... but honestly I don't think it will show up if you have the bios setup incorrectly... (ex. Legacy only bios OS install iso without legacy settings set in bios.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.