0

I installed ubuntu 18.04.4 LTS 2 days on a desktop with intel processor and integrated VGA, and was downloading and configuring everything how I liked, including xubuntu-desktop, but I was using gdm3. And I had no problem during these 2 days. I did shutdown the computer and reboot many times after the installation and had no problem whatsoever prior to today.

But when I started the machine today it was stuck in this screen for a while. As you can see the last line is "Started Unattended Upgrades Shutdown", but when I rebooted it got stuck again but with a different message. But one thing that they had in common was that it was just after "Started Gnome display manager". When I tried using a tty it wouldn't work, it would be flashing the screen or the characters I type would not come up. I tried choosing an older version of the kernel on grub but nothing changed. After searching a lot online I tried booting with recovery mode, and uncommented the WaylandEnable=false line on /etc/gdm3/custom.conf but still same problem. Than on recovery mode I ran systemctl set-default multi-user.target and I was able to get access to tty after reboot. But when I started gdm, I got the same problem. So I reboot again, set up to use lightdm instead of gdm3, and started lightdm, but now I get a black screen with a flashing underline cursor on the top left corner.

I have been trying to find a solution for this for hours now because I don't want to have to format my machine and have to configure everything again, since that is what I have been doing this last 2 days, and also I have no guarantee that the problem will not repeat itself, given that I don't know what caused it, and most of the configuration I did was pretty basic like installing new software.

0

For anyone having similar problems, after trying a lot of stuff, running these commands solved it:

sudo dpkg --configure -a
sudo apt -f install
sudo apt update
sudo apt dist-upgrade

As this was probably caused by unattended upgrades, I disabled unattended upgrades after that.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.