3

My WiFi adapter stopped discovering networks today. After a reboot the adapter is not even loaded.


Running Ubuntu 18.04

Secure boot is disabled.

  • dmesg | grep iwl

    [ 6.154661] iwlwifi 0000:00:14.3: enabling device (0000 -> 0002) 
    [ 6.249463] iwlwifi: probe of 0000:00:14.3 failed with error -110
    
  • lshw -c network

    *-network UNCLAIMED       
         description: Network controller
         product: Wireless-AC 9560 [Jefferson Peak]
         vendor: Intel Corporation
         physical id: 14.3
         bus info: pci@0000:00:14.3
         version: 10
         width: 64 bits
         clock: 33MHz
         capabilities: pm msi pciexpress msix cap_list
         configuration: latency=0
         resources: iomemory:600-5ff memory:604411c000-604411ffff
    *-network
         description: Ethernet interface
         product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
         vendor: Realtek Semiconductor Co., Ltd.
         physical id: 0
         bus info: pci@0000:02:00.0
         logical name: enp2s0
         version: 0c
         serial: 90:20:3a:1b:d8:1d
         capacity: 1Gbit/s
         width: 64 bits
         clock: 33MHz
         capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
         configuration: autonegotiation=on broadcast=yes driver=r8169 firmware=rtl8168g-2_0.0.1 02/06/13 latency=0 link=no multicast=yes port=MII
         resources: iomemory:600-5ff irq:17 ioport:3000(size=256) memory:58200000-58200fff memory:6042200000-6042203fff
    
  • lspci -v

    00:14.3 Network controller: Intel Corporation Wireless-AC 9560 [Jefferson Peak] (rev 10)
      Subsystem: Intel Corporation Device 0034
      Flags: fast devsel, IRQ 16
      Memory at 604411c000 (64-bit, non-prefetchable) [size=16K]
      Capabilities: [c8] Power Management version 3
      Capabilities: [d0] MSI: Enable- Count=1/1 Maskable- 64bit+
      Capabilities: [40] Express Root Complex Integrated Endpoint, MSI 00
      Capabilities: [80] MSI-X: Enable- Count=16 Masked-
      Capabilities: [100] #00
      Capabilities: [14c] Latency Tolerance Reporting
      Capabilities: [164] Vendor Specific Information: ID=0010 Rev=0 Len=014 <?>
      Kernel modules: iwlwifi
    
  • rfkill list

  • modprobe iwlwifi

  • iwconfig

    enp2s0    no wireless extensions.
    
    lo        no wireless extensions.
    
  • dmesg | grep -i firmware

    [    0.211684] Spectre V2 : Enabling Restricted Speculation for firmware calls
    [    1.242245] [Firmware Bug]: Invalid critical threshold (0)
    [    6.219664] [drm] Finished loading DMC firmware i915/kbl_dmc_ver1_04.bin (v1.4)
    

I tried to re-install iwlwifi as per Unable to get wifi adapter working - clean 19.04 install - network unclaimed, but the error persists:

  • dmesg | grep iwl

    [    6.015501] Loading modules backported from iwlwifi
    [    6.015502] iwlwifi-stack-public:master:8613:3ae69204
    [    6.085935] iwlwifi 0000:00:14.3: enabling device (0000 -> 0002)
    [    6.179958] iwlwifi: probe of 0000:00:14.3 failed with error -110
    
  • lsmod | grep iwl

    iwlwifi               385024  0
    cfg80211              704512  1 iwlwifi
    compat                 16384  2 iwlwifi,cfg80211
    

Any pointers would be greatly appreciated!

3 Answers 3

2

I had a similar error for the longest time, upgrading the kernel has fixed it for me.
Run this to upgrade the kernel intelligently with all the dependencies:

sudo apt-get dist-upgrade
2
  • Update my problem was actually because of dual boot because of windows power management askubuntu.com/questions/984303/… this solved it for me. Aug 19, 2021 at 5:12
  • Thank you very much. After wasting a lot of time with other solutions, yours solved my problem. Feb 4, 2022 at 13:33
1

This problem persists with Intel Wireless-AC 9560. Till now, there is no solution for this. I have tried everything from switching to older kernel to updating the drivers. There can be some work arounds:

  1. Use external WiFi adapter.
  2. Use USB Tethering from your phone.
0

I fixed this issue by the command: sudo apt install backport-iwlwifi-dkms

Then restart system.

It should work, because it reinstalls Intel adapter stuff.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .