7

I am trying to upgrade from 11.10 to 12.04 and the upgrade seems to be stuck downloading ttf-mscorefonts. Is there a way to bypass this?

Output from /var/log/dist-upgrade

    Installing new version of config file /etc/xdg/autostart/print-applet.desktop ...
    Setting up ubuntu-wallpapers-precise (0.34.1) ...
    Setting up ubuntu-wallpapers (0.34.1) ...
    Setting up adium-theme-ubuntu (0.3.2-0ubuntu1) ...
    Setting up update-manager-core (1:0.156.14) ...
    Installing new version of config file /etc/update-manager/release-upgrades ...
    Setting up update-notifier-common (0.119ubuntu8.1) ...
    ttf-mscorefonts-installer: downloading http://downloads.sourceforge.net/corefonts/andale32.exe
    -- 0:precise -- time-stamp -- Apr/27/12  8:15:21 --
    -- 0:precise -- time-stamp -- Apr/27/12  8:20:10 --


    -- 0:precise -- time-stamp -- Apr/27/12  8:22:01 --
    -- 0:precise -- time-stamp -- Apr/27/12  8:55:14 --



    phiri@PHRLIG001:/var/log/dist-upgrade$ lsb_release -a
    LSB Version:    core-2.0-ia32:core-2.0-noarch:core-3.0-ia32:core-3.0-noarch:core-3.1-ia32:core-3.1-noarch:core-3.2-ia32:core-3.2-noarch:core-4.0-ia32:core-4.0-noarch
    Distributor ID: Ubuntu
    Description:    Ubuntu 12.04 LTS
    Release:    12.04
    Codename:   precise
    phiri@PHRLIG001:/var/log/dist-upgrade$ 
  • I'm having exactly the same problem. Could anyone tell us if it's ok to cancel the update process and relaunch it again? – user57166 Apr 27 '12 at 11:07
11

I've got the exact same issue, the upgrade hung off while downloading ms-core-fonts from sourceforge. After 2 hours waiting for the process to continue, I decided to kill the process downloading the package.

So I just ran "sudo htop" then F5 to see the tree of process, I started from the main process responsible for the upgrade to precise and searched for the one reponsible for the download. I killed this one, then the process skips the ms-core-font download part then continues and finishes the updrage to precise.

If you don't have the htop, just try ps -ejHf and find the package-data-downloader and kill it.

root     29696 11731 29696 29696  0 22:46 pts/2    00:00:04           /usr/bin/dpkg --force-overwrite --status-fd 56 --configure dmsetup libdevmapper1.02.1 libfreetype6 g
root     22330 29696 29696 29696  0 23:02 pts/2    00:00:00             /bin/sh /var/lib/dpkg/info/update-notifier-common.postinst configure 0.117ubuntu3.2
root     22332 22330 29696 29696  0 23:02 pts/2    00:00:00               /usr/bin/python /usr/lib/update-notifier/package-data-downloader
  • Thank you --this really helped; finally managed to install precise. – lightonphiri Apr 28 '12 at 7:31
  • To kill that process, I ran: sudo pkill -s sidOfTheProcess (that is the SID of the process 'package-data-downloader') – heiko81 Sep 12 '12 at 20:06
1

You could remove the package and then reinstall it when you have the rest of the system upgraded, I suppose. It is not supposed to fail while downloading the fonts, of course, but if source forge is down for you right now, it might be a workaround option.

  • @Lacritsbollar So should I just terminate the whole process? How then do I proceed after that --how do I continue from where setup process stopped from and how do I know which package(s) to remove? – lightonphiri Apr 27 '12 at 8:30
1

Additional info: I have had exactly the same problem when fresh-installing Kubuntu 12.04 and using a list of installed packages from another machine, which contains Kubuntu 12.04 upgraded from Kubuntu 11.10. I gave in "ttf-mscorefonts-installer" in the system monitor. Then, I found a process related to the failed installation of ttf-mscorefonts-installer. It failed, because I could not indicate accepting the software license terms. So, I killed the process related to it. Than, I went to the MUON package manager. There, I again gave a command to upgrade ttf-mscorefonts-installer: now it works. I could via the MUON gui indicate to accept the terms. Then, everything ran smoothly. Problem solved.

1

I had the same issue with ttf-mscorefonts-installer when upgrading to 16.04 from 14.04. I tried killing processes related to ttf-mscorefonts-installer via htop (both SIGTERM and SIGKILL) which did not work for me. I did some further digging and found that I had neglected to hit the Tab, which highlights OK and allows the Enter key to continue the process as outlined here. I felt pretty stupid until I realized that it would have been extremely simple to include the words "Hit tab and then enter to accept" on the page that requests acceptance. I have no doubt that making this small adjustment would eliminate a great deal of frustration.

0

ttf-mscorefonts is not available for 12.04 as of now So the upgrade process is stuck since you have it already installed in your current version. Remove the package and try upgrading

You could also refer to https://launchpad.net/ubuntu/precise/+package/ttf-mscorefonts-installer

protected by Community Aug 19 '13 at 15:41

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.