0

I installed TeamTalk from http://bearwear.dk inside my home directory, but when I try to run ./tt5srv -wizard I get

error while loading shared libraries: bdl.so.2: cannot open shared object file: No such file or directory

I tried with and without sudo

I found fixes for other libraries but I didn't see any mention of bdl.so.2.

Ubuntu 18.04. How to fix this? Is it another case of wrong location or symlink?

1
  • I appreciate the edits. I couldn't type it better. – Joey Jul 15 '20 at 11:39
0

Before running TeamTalk, you'll need to install some dependencies.

you can install it by typing

sudo apt install libqt5x11extras5 libqt5webenginewidgets5 \
libqt5webenginecore5 libqt5quick5 libqt5widgets5 \
libqt5multimedia5 libqt5gui5 libqt5webchannel5 \
libqt5qml5 libqt5network5 libqt5xml5 libqt5core5a libasound2

in terminal.

Source: README file in TeamTalk

8
  • I edited my post for the correct software. – Joey Jul 15 '20 at 11:23
  • Did you try this answer? – kashish Jul 15 '20 at 11:28
  • Yes. I copy-pasted everything but the error persists. I'll check again. – Joey Jul 15 '20 at 11:29
  • are you running by ./run.sh ? – kashish Jul 15 '20 at 11:31
  • run.sh? I run ./tt5srv -wizard. I am expecting the program to display a wizard to setup a configuration file. On CentOS I had almost similar issue but it was looking for libssl.so.10 which I was able to solve. But this bdl.so.2 is new to me. – Joey Jul 15 '20 at 11:35
0

I fixed this by upgrading to Ubuntu 20.04.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.