I'm using a lenovo yoga, with ubuntu 20 and a usb-c to hdmi converter. I'm also using a secondary screen. However, the hdmi connection never works on boot. I'll have to unplug the hdmi cable, and re-insert it for it to work again.

Can I do something for the laptop to automatically find this hdmi connection on boot? Would love your input on this issue.

The lenovo uses Intel UHD Graphics 620.

  • Is this helpfull? askubuntu.com/questions/968883/… it is not exactly your question.
    – nobody
    Jul 24, 2020 at 11:51
  • Append the question with the output of xrandr before USB reconnection.
    – Ruby
    Jul 27, 2020 at 19:14

4 Answers 4


I would comment but I can't, sorry. I had a very similar problem a few years ago on ubuntu 16.04. I had to unplug the hdmi cable and plugin again every time I turned on the laptop. I was using NVIDIA driver and I have accidentally discovered that when I switched to Nouveau driver the problem disappeared. Later on with an upgrade the problem was fixed for the Nvidia driver as well.


There are similar problems reported here:

  • Bug: Monitor plugged in with USB-C/DisplayPort is not connected on boot (have to manually replug)

The description of the problem:

I am using the USB-C to DP adapter provided by XMG and BIOS version 0060.

Every time I boot or restart my Fusion 15, my monitor plugged in with USB-C is not connected. It stays off, and does not show in Display Settings. My HDMI monitor starts fine.

Only when i unplug & re-plug the USB-c cable, the screen turns on and is connected like it's supposed to.

Of the many comments the most relevant:

So they fixed it in 0056; broke it in 0060; fixed it again in 0062, and now broke it again in 0064? What are they doing over at Intel???

Funny because that's one of the things specifically mentioned in the 0064 changelog: https://www.reddit.com/r/XMG_gg/comments/ea8vtn/xmg_fusion_15_drivers_firmware_bios_updates/

Thanks for the heads up, I hadn't updated yet. I suggest you downgrade to 0062 if you want to fix it. Tagging /u/XMG_gg


It might be worth while having a look at your UEFI configuration. Controlling how external devices are attached is possible with Dell laptops.


I recently tried another adapter, where my problem does not appear. I tried out the tips from the answers but only another adapter solved the problem.

  • 2
    There is also the option of USB-C monitors, eliminate the adapter altogether.
    – rtaft
    May 21, 2021 at 12:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.