I'm trying to install npm and I found this solution.
aptitude install npm and the suggested solution is
The following packages have unmet dependencies: libssl-dev : Depends: libssl1.1 (= 1.1.1f-1ubuntu2) but 1.1.1g-1+ubuntu18.04.1+deb.sury.org+1 is installed Keep the following packages at their current version: 1) libnode-dev [Not Installed] 2) libssl-dev [Not Installed] 3) node-gyp [Not Installed] 4) npm [Not Installed] Accept this solution? [Y/n/q/?]
It's basically suggesting to downgrade, but what impact would that have on my system if I downgrade libssl1.1 to libssl1.0?
Edit: this problem resulted after upgrading Ubuntu 18.04 to 20.04. Dan Scally's solution works and I also provided another option in the comments from launchpad where it's a bit more detailed for my particular situation.