1

I recently upgraded to 20.04 LTS from 18.04 LTS and now both my left and right alt keys are not working when I try to use them for any keyboard shortcuts. I had no issues before upgrading. My keyboard mapping hasn't changed since the update (Macintosh UK).

Any help would be greatly appreciated.

Edit updated with xmodmap output

xmodmap:  up to 4 keys per modifier, (keycodes in parentheses):

shift       Shift_L (0x32),  Shift_R (0x3e)
lock        Caps_Lock (0x42)
control     Control_L (0x25),  Control_R (0x69)
mod1        Alt_L (0xcc),  Meta_L (0xcd)
mod2        Num_Lock (0x4d)
mod3      
mod4        Super_L (0x85),  Super_R (0x86),  Super_L (0xce),  Hyper_L (0xcf)
mod5        ISO_Level3_Shift (0x5c),  Mode_switch (0xcb)
6
  • What does xmodmap tell about Alt? Then you could try xev to find out what the key actually do. – jarno Jul 13 '20 at 16:00
  • @jarno thanks - have updated original post with xmodmap output. Looks like the key is triggering ISO_Level3_Shift from xev output. – barnsley92 Jul 13 '20 at 17:50
  • Oh, the table shows it knows only left alt key. Have you tried if setting different keyboard model helps? – jarno Jul 14 '20 at 8:12
  • I've tried setting several different varations of the english language layout in the settings if that's what you're referring to? However this didn't seem to have any effect. – barnsley92 Aug 4 '20 at 8:30
  • 1
    resolved by changing the keyboard model via dpkg-reconfigure - thanks @jarno – barnsley92 Aug 7 '20 at 8:32
1

I have fixed this by changing the keyboard model via dpkg-reconfigure which then gave options to map the alt key which I could not figure out how to do using the keyboard settings in the GUI.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.