0

enter image description here

I have installed ubuntu-20.04-desktop-amd64.iso in Oracle VM VirtualBox. The details are above. I have tried both Minimal Installation and Normal Instalation type while installing Ubuntu. The following problem is in both instances.

When I tried to open Google.com earlier in firefox, I got error code sec_error_unknown_issuer on clicking advanced button. There is no button accept the risk and continue

After few minutes I was working in Host OS(windows 10) I tried again now I got error code as MOZZILA_PKIX_ERROR_MITM_DETECTED with accept the risk and continue button. I can't understand what changed the error code and made the accept and continue option available.

Also I tried from earlier to install postman from terminal by this comman

sudo snap install postman

It's always failing

error: cannot install "postman": Post
       https://api.snapcraft.io/v2/snaps/refresh: x509: certificate signed by unknown authority

In /usr/share/ca-certificates directory there is only one directory name mozilla

After researching about certificate authority, I guess I may need to install a root certificate. But I got my question now, "Won't Ubuntu installation take care of installing root certificate ?"

Do we need to install root certificate after installing OS (windows, Mac or any OS) ?

4
  • Try changing your DNS.
    – kashish
    Jul 13, 2020 at 11:20
  • 1
    Ubuntu will happily install certificates with the rest of the normal desktop install...but you chose a Minimal install. So installing those certificates is up to you.
    – user535733
    Jul 13, 2020 at 13:53
  • @user535733 I have installed another VM instance with same iso. This time it is Normal installation not minimal one. the same problem exists in the normal installation also. Jul 13, 2020 at 17:02
  • 1
    How strange. I happened to do a test install of Ubuntu 20.04 Desktop in a VM yesterday for unrelated reasons...and the browser works perfectly - no certificate errors.
    – user535733
    Jul 13, 2020 at 17:05

1 Answer 1

0

No, users don't need to install any certificates separately to access websites like google.com or Bing.com

This certificate issues were solved by disabling BC Unified Agent

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.