0

I have this old MacBook Pro, model 2,2 (from late 2006) that I thought I’d revisit, and put Ubuntu on (the optical drive doesn’t work anymore, so making a live DVD won’t help). I want it to dual boot into Mac OS X. So after a hit of reading, I partitioned the HD, and also got rEFInd working.

The machine supports 64bit, but has a 32 bit EFI. I have been down a very deep rabbit hole with a lot of stuff I don’t fully understad (GRUB, EFI stuff, etc. etc). My understading from everything I’ve read up until now is that it would be simple. I even tried an install on a virtal machine on a newer Mac to see what to expect in the Ubuntu install process.

I can not for the life of me get the Ubuntu live CD to boot. I have followed various instructions on making a USB stick with the live CD image on it, but nothing seems to work.

I started with the most current version - 20.04. Download the .iso file and off I went.

So first off, I started here: https://ubuntu.com/tutorials/create-a-usb-stick-on-macos#1-overview

Nothing happenms. rEFINd and even booting with the ALT key held down reveals no bootable drive.

Rinse and repeat, using Etcher to make the USB stick. Same as before - no show on the boot screens on the Mac.

Apparently, it will work if you use some command line to convert the .iso to a .img file. So I tried that.

hdiutil convert /path/to/ubuntu.iso -format UDRW -o /path/to/target.img

That’s a no-go too.

Worth pointing out that at this juncture, the .iso and .img files are not mountable, and the USB stick is not mountable either, so I don’t know what is (or isn’t) in the file structure that may need changing.

OK, so I then find out that there needs to be a little tinkering to get the installer to work. Fine, I’m OK with that. Seems that if I use a tool like Mac Linux USB Loader, I can get something working - I can actually see the file structure, and there’s a single folder structure: /efi/boot/

with boot.iso and a .efi file. I read that if I remove the 64 bit EFI file, and put in a file called bootia32.efi, that will work. And....

It boots! But, hold your horses. It goes so far - loads Linux, loads RAM disk, then gets stuck on loading the kernel. And, yes, I have been patient and have left it a while, but nothing happens. After an hour with nothing more happening, I decided that it probably isn’t working.

Picture of the Loading Kernel screen where it gets stuck

Also tried UNetBootIn - same thing.

So, onwards. I found this page: https://mattgadient.com/linux-dvd-images-and-how-to-for-32-bit-efi-macs-late-2006-models/

Where I learn that there may need to be some tinkering with the .ISO file. Fair enough, I’ll try that. I also follow the instructions linked to in that page to create a partitioned USB stick with USB partitions. Matt says that this is the best one to try, so I go off and click the link and follow the instructions. https://mesom.de/efi32boot/index.html Worth pointing out here that I don’t have another Linux box kicking around, so I have to do this in Mac OSX using DiskUtility to partition the drive.

And I try this, and again something different happens. I get a boot screen, and option to boot Ubuntu and then a blank screen with just a static cursor in the. That’s stuck too.

I get this: Start of Boot cycle

followed by this (and I feel I may be getting somewhere here): Second phase of boot cycle

And then: Third phase of boot cycle

And it gets stuck. Nothing happens. The cursor doesn’t flash.

I have tried this, as I said with 20.04 - I have also treed earlier downloads which are apparently meant for Macs, but with similar failures. At best, I get to the “loading kernel” bit before it all grinds to a halt.

I have been at this for a few days - these tests involve shunting a lot of data about.

I have also tried installing Ubuntu usiung a Mac that does work with the USB drive and then trying to move that install to the target machine. No go. Also tried migrating a VM from Virtual Box - again no go. Also tried making a DVD, booting another Mac in targeted disk mode and trying to access it from the target machine. No go there either (no DVD showed up - again, the Macs reject).

I am now feeling pretty frustrated. Something that seems easy has become more complex than I expected.

Any pointers, especially from people who have managed to get this working on this model of MacBook Pro, will be very welcome. Thanks!

0

You said you couldn't get the cd to boot but the optical drive is broken so I assume you're using USB. Where did you download the file ubuntu.com? Some other sources will not properly download or the download just got corrupted. Try redownloading from ubuntu.com and see if that works.

2
  • Thanks for the answer - I have been downloading the iso files from ubuntu.com. To test the USB sticks, I have been able to boot them with a newer Mac, so they do work, but just not on the machine I am wanting to use. Sorry, probably not made myself clear on the DVD not booting. I connected the MacBook Pro to another Mac with a working DVD drive using targeted disk mode. What this does is give you access to the drives on the connected Mac as if they were mounted directly. Usually, you can get DVDs to mount, but not this time - the DVD is rejected by the machine and ejected. Jul 13 '20 at 18:30
  • OK did you try the redownload? sometimes it just doesn't work when you download. After that, I have no idea Jul 13 '20 at 18:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.