4

I've installed Ubuntu 20.04 on a Lenovo Ideapad 330 as single operating system. In normal boot on my laptop, after choosing the operating system at the GRUB menu it shows some ACPI BIOS ERROR and other messages and then the system starts normally.

This happens every time while starting & restarting my system. I've attached some images & video of this code.

GRUB menu

boot messages

boot messages

boot messages

Video clip showing the boot process with these messages

1

2 Answers 2

3

The bugs you are seeing are harmless. Apparently, because of Microsoft's market dominance, the faulty ACPI implementation from Microsoft has become the de facto industry standard. As a result, Linux and other non-Microsoft operating systems have to reverse engineer the faulty ACPI implementation from MS.

Things you may try:

  • You could try upgrading your BIOS. Here on the Lenovo support website is the latest available firmware for your Lenovo Ideapad 330 and this question explains about upgrading BIOS: How to update the computer bios firmware without using Windows.

  • Use UEFI mode instead of BIOS legacy mode, if system supports.

  • Install intel-microcode non-free package.

  • To just turn off these messages, you may edit /etc/default/grub and add to the line GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" the parameters acpi=off or noacpi acpi=strict and then run sudo update-grub2.

References:

1

I have looked at the images and the video, and we are talking about a very common error regarding ACPI BIOS, it allows you to discover computer hardware components and solving this error is not easy because it varies depending on the device in use. Here are the three main methods that are right for me, but don't follow all these methods, make sure that what you used doesn't work before proceeding with the others:

  1. On the grub screen, press "e" and in the line with "Linux" add the following at the end modprobe.blacklist=nouveau

  2. Disable ACPI: My solution is similar, but I recommend that you follow this even more

    a) How do I disable ACPI when booting?

  3. If you can't solve the problem, you can use this last method:
    a) Study the Lenovo BIOS and look for some settings by the use of ACPI,after format your computer and re-install your distro.
3
  • reinstalling the distro won't solve this!
    – kashish
    Jul 13, 2020 at 8:43
  • @loreame thanks for ur effort. i tries your solution 1 not working. for solution 2 i dont have an option like acpi_off (image link-u.pc.cd/O7T7) i need to try solution 3
    – Naveen Raj
    Jul 14, 2020 at 10:41
  • where and what is the hell grub screen? Jul 27, 2021 at 11:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.