I just upgraded my Ubuntu 11.10 (x86) to Ubuntu 12.04 (x86). The upgrade completed without any errors.

Since then, I am unable to access any of the applications in the Dash. The Dash seems to be empty. When I search for some application like gedit, it says "Sorry, there is nothing that matches your search".

Is there any way to fix it?


None of these fixes worked for me. But after more searching:

rm ~/.cache/software-center -R

worked like a charm. I did need to run:

unity --reset &

afterwards though, for the changes to take effect within dash, but the software center just started working straightaway.

  • 7
    In Ubuntu 13.10 the second command gives: ERROR: the reset option is now deprecated Feb 24 '14 at 13:56
  • 4
    In Ubuntu 14.04 I have the same issue: ERROR: the reset option is now deprecated Jun 15 '14 at 13:14
  • 3
    unity --replace & is the non-deprecated version.
    – ulidtko
    Nov 14 '15 at 15:05
  • Well, for 16.04 this just worked! Although Ubuntu crashed and I had to power-cycle the machine.
    – OmarOthman
    Oct 19 '16 at 14:36

You should ensure that you have these 2 packages installed:

Then logout/login and you will get back you the 2 lenses and the search will search applications and files.

  • I had a fresh install of 12.04, not an upgrade. Just wanted to point that out since someone else had said that one of the previous answers was for upgrade path only. These packages were not installed. Once installed, all was well with the world.
    – twindham
    Feb 7 '13 at 19:23
  • These packages seem to be unavailable on 14.04.
    – jobin
    Jun 16 '14 at 12:47
  • Instead of doing a logout/login I executed unity --reset &, it worked!
    – dusan
    Aug 18 '14 at 16:24
  • 2
    In Ubuntu 14.04 they are called unity-place-applications and unity-lens-files
    – MadMike
    Sep 27 '14 at 8:16
  • 2
    @MadMike thanks. But the are both called unity-lens-…
    – jmk
    Nov 24 '14 at 10:44

In my case none of the solutions above worked.

The solution I found:

rm -rf ~/.local/share/zeitgeist

Then close your session and login again, and dash worked again.

  • This is the only solution which helped me. In my case dash stopped to search for applications after a forced shutdown. Jan 6 '15 at 13:23

Same here. After upgrading from 11.04 to 11.10 to 12.04 (beta2) the DASH menu doesn't list any applications. Previously typing "calc" for example would list the calculator and LibreOffice Calc. Now, nothing shows up, neither in the main DASH window, nor in the application lens.

However, in the main lens songs (FLAC) do show up, but for instance documents don't. Furthermore, I have regular crashes of unity-lens-video. Apport told me this problem had already been reported. Maybe this is related?

Looking a bit closer in ~/.xsession-errors I found that the zeitgeist daemon crashed:

(zeitgeist-datahub:2329): LibZeitgeist-CRITICAL **: Unable to connect to Zeitgeist daemon: Error calling StartServiceByName for org.gnome.zeitgeist.Engine: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Process /usr/bin/zeitgeist-daemon exited with status 1

According to https://bugs.launchpad.net/ubuntu/+source/zeitgeist/+bug/986191 this happens when upgrading from Ubuntu 11.04 to 12.04. Removing ~/.local/share/zeitgeist/activity.sqlite solves the problem. I tried it and it works :-).

  • 1
    Note that this answer is specifically for the 11.04 -> 12.04 upgrade path. For those updating from Oneiric (11.10), this doesn't apply. Jul 10 '12 at 8:40

I just encountered this problem earlier today on my laptop. It surprised me, given that I couldn't think of any reason it didn't show up until now.

After some struggling, I eventually resolved the issue by opening a terminal (Ctrl+Alt+T if you don't already have it pinned to the launcher) and using unity --replace &. (You could probably also do this with Unity's Alt+F2 prompt, but it too went missing for me at the time.)

  • Works great! This command will log you out and discard the previous session. So save everything important before.
    – czerasz
    Apr 24 '15 at 11:32
  • @czerasz This shouldn't log you out, just restart the Unity shell. What you're describing sounds more like a crash. Apr 27 '15 at 2:23
  • @Christopher Kyle Horton NO this is not a crash. For example upon the restart of a new session, you will keep access to external storage without having to re-type the password. But all your previously opened windows are lost, as you start a new session. That's why you better save your work before.
    – Antonio
    Oct 8 '15 at 14:19
  • @Antonio I've never lost any of my open windows before when running this command. It only restarts the Unity shell, not the whole session. That's what suggests a crash to me if you run this command but your windows aren't kept; something went wrong in the process. Oct 9 '15 at 6:11

I experienced this problem on 11.10 and solved it by installing unity-place-applications and unity-place-files

  • 2
    These packages seem to be unavailable on 14.04.
    – jobin
    Jun 16 '14 at 12:48
  • @i08in: unity-lens-applications and unity-lens-files are what you need. $ dpkg --get-selections | grep -v deinstall | grep unity-lens-applications unity-lens-applications install $ dpkg --get-selections | grep -v deinstall | grep unity-lens-files unity-lens-files install
    – OmarOthman
    Oct 19 '16 at 14:43

In Ubuntu Trusty 14.04, I loosed all Applications in Dash after an Ubuntu Update of update-manager-core package.

The solution was:

$ rm ~/.cache/software-center -R

However as said earlier here the unity --reset command is now deprecated. the solution is now:

<Alt> <F2> and type unity

This will kill your session (please save your work before) and restart unity.

Not the answer you're looking for? Browse other questions tagged or ask your own question.