Possible Duplicate:
Unable to use package manager due to “exclusive lock” error

I use Ubuntu 11.10 on my desktop PC. My update manager shows me the upgrade link to 12.04 LTS but when I click on it, and follow the instructions, my installation halts at the small 'Distribution Upgrade' window that shows the steps that the installation takes to install the new package (e.g 'preparing to upgrade' and 'setting new software channels' etc). Not even a second after the 'distribution upgrade' window appears, a error message saying 'Unable to get exclusive lock' appears with the message:

This usually means that another package management application (like apt-get or aptitude) already running. Please close that application first.

I then clicked cancel and went back to the update manager to try again. There I unchecked all the updates and then clicked on the 'upgrade' to 12.04 button and the same thing happens again. I tried with different user accounts but still no change.

This is not the first time I used to install Ubuntu via update manager. I first installed Ubuntu 10.10 from the live CD and then when Ubuntu 11.04 and 11.10 came out I installed them via update manager with no problem.

Please help me solve this.


Ok, try some of these steps in order:

If you haven't already done so reboot your machine and try running the update again.

Try running sudo apt-get clean in a terminal and try running the update again

Try the command line upgrade by running sudo do-release-upgrade

Manually remove the lock file sudo rm /var/lib/dpkg/lock and try running the update again.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.