5

I just installed Ubuntu 20.04 on a clean SSD alongside windows to do C development and when I first booted, there was no internet connection yet my ethernet worked perfectly in windows.

My network controller is the realtek RTL8125 2.5 gb and is labelled "UNCLAIMED" when I run the lshw -C network command. I can access the internet using a USB tether to my phone but nothing I have tried so far has fixed the problem.

Would appreciate any help

6
  • Please edit your question and add output of lspci -knn | grep Eth -A3 terminal command.
    – Pilot6
    Commented Jul 11, 2020 at 16:04
  • You need to install r8168-dkms: apt install r8168-dkms
    – Serafim
    Commented Jul 11, 2020 at 16:29
  • @Serafim Why do you think r8168-dkms is needed?
    – Pilot6
    Commented Jul 11, 2020 at 16:41
  • @Pilot6 It is listed on reposcope.com/package/r8168-dkms as the driver for RTL8125
    – Serafim
    Commented Jul 11, 2020 at 18:08
  • Is this a desktop or server installation? Edit your question and show me sudo lshw -C network and cat /etc/network/interfaces and cat /etc/netplan/*.yaml. Start comments to me with @heynnema or I'll miss them.
    – heynnema
    Commented Jul 11, 2020 at 19:17

2 Answers 2

6

i had the same exact issue. i was missing drivers for the Ethernet.

Go to Realtek site from the actual Ethernet provider. Download the "2.5G Ethernet LINUX driver r8125 for kernel up to 5.6" and follow the install instruction.

You should be able to use wired connection once your done.

1
  • Downloaded the exact same driver, uncompressed it, ran ./autorun.sh as sudo and now I have Ethernet on my linux distribution Pop!_OS. This answer worked great!
    – Tono Nam
    Commented Apr 7, 2022 at 19:20
3

This driver exists on the ubuntu repositories, the package is called: r8168-dkms. Yes, this works for the realtek 8125 wired ethernet connection.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .