2

When I start my notebook and my TV screen stays off and is switched on afterwards, I have to type on the keyboard to see the login area. Does anyone know why?

In addition, my Ubuntu Desktop 20.04 seems to continue to switch off the display after a certain time, even though it is connected to the socket.

Under "Energy" > "Turn off screen", the setting is set to "Never".

1

Under System Settings -> Power there should be two settings called "Dim Screen When Inactive" which is a toggle switch and "Blank Screen" which selects a time before the screen is turned off.

If you do not wish to have the screen turned off after a period of inactivity, you should disable this setting.

1
  • I don't find any option like "Dim Screen When Inactive". There is only a "Power saving" area with "Blank screen" -> "Never" option selected. Where can I find this setting? – Mike Jul 11 '20 at 15:20
0

Don't know if this is the preferred way:

xset s off && xset -dpms

I paste it on the end of the .profile file in home directory. When I lock my screen I don't see the lock screen (preferred final solution) but a black window and monitor stays on.

Other solutions like the following won't work for me:

gsettings set org.gnome.desktop.session idle-delay 0
0

In the category 'Privacy', there should be a Screen Lock menu. Inside of that, you should see two options, called 'Blank Screen Delay' and 'Automatic Screen Lock.' Make sure those are set to Never and toggled off.

If that doesn't work, you can try using this terminal command:

systemctl mask sleep.target suspend.target hibernate.target hybrid-sleep.target
5
  • Is there a way for activated automatic screen lock but disabled power off screen? Thank you! – Mike Jul 13 '20 at 2:20
  • @Mike What do you mean by disabled power off screen? – geixco Jul 13 '20 at 15:48
  • 1
    I want that my ubuntu automatically locks my screen after 30 minutes. But when I use <system> + L or the screen automatically get locked, my tv screen should show the login mask or lock screen background image and don't show a black screen or hdmi signal get lost and not that my samsung screen in this case shows a message like "no signal hdmi" (until I press a key again). – Mike Jul 13 '20 at 22:03
  • 2
    In this case, you'd want to go to Settings > Power > Screen Lock, where you can enable the 'Automatic Screen Lock' feature. Make sure the 'Blank Screen Delay' is set to Never. If you're still having issues with the screen when locking manually, you can try using this GNOME extension – geixco Jul 14 '20 at 6:39
  • The gnome extension works for me! Thank you very much! – Mike Jul 18 '20 at 12:00
0

As @geixco mentioned in a comment; there's a gnome extension called unblank lock screen

When enabled, your computer will still lock as expected, but the screen will not go black or power-off your displays. It will just 'stay on' the lock screen.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.