0

I had a single HDD with 2 partitions, one for the OS and the other for my data. Now I added a SSD and made a fresh Linux install, following the same 2-partitions logic. Result: now I have 2 hard drives and a total of 4 partitions:

  • HDD1: old Linux installation
  • HDD2: my data
  • SSD1: new Linux installation
  • SSD2: my new space for data

I changed the BIOS boot order and I can chose between old and new Linux at start up. I can enter into the new Linux installation (not into the old one, but that is not a problem now).

I want the 4 partitions to be normally accessible, with only the new Linux installation (SSD1) as the OS partition. The other 3 should be "normal data use" partitions.

So my objectives are:

  1. have the 4 partitions mounted and writable at start up,
  2. remove the grub menu at startup (I want to go directly for the new installation) (Edit: see solution here),

The problems:

  1. Only SSD1 (new Linux) and HDD2 (old data) are mounted and writable at startup. SDD2 (new data) seems to be mounted but I can not write on it. HDD1 (old Linux) is not even mounted.
  2. I don't know how to deactivate grub's "choose OS" at startup (Edit: solved using this post)

I have done and solved fstab problems before, but apparently I ..ehem.. enough to ask again for help with the same thing (facepalm)

I have tried with Disks but I can't seem to solve it.

This is the output of sudo blkid

/dev/sda1: LABEL="r.linux.HDD" UUID="20e5d70f-3982-482d-a9eb-3dfeaf8f6fd7" TYPE="ext4" PTTYPE="dos" PARTUUID="63f35bc3-01"
/dev/sda2: LABEL="r.all" UUID="96782954-2c88-4c7a-87d1-f42396d80456" TYPE="ext4" PARTUUID="63f35bc3-02"
/dev/sdb1: LABEL="Linux_SSD" UUID="eea663dc-aa20-4029-a86e-7f9f8ce67bbe" TYPE="ext4" PARTUUID="bd5fa220-01"
/dev/sdb2: LABEL="r.all.SSD" UUID="373e4ca3-d51e-4ffa-b546-4e8a815a5c17" TYPE="ext4" PARTUUID="bd5fa220-02"
/dev/loop0: TYPE="squashfs"
/dev/loop1: TYPE="squashfs"
/dev/loop2: TYPE="squashfs"

This is the output of sudo fdisk -l

Disk /dev/loop0: 54.97 MiB, 57618432 bytes, 112536 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/loop1: 163.68 MiB, 171618304 bytes, 335192 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/loop2: 29.84 MiB, 31272960 bytes, 61080 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/sda: 931.53 GiB, 1000204886016 bytes, 1953525168 sectors
Disk model: ST1000LM024 HN-M
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: dos
Disk identifier: 0x63f35bc3

Device     Boot     Start        End    Sectors   Size Id Type
/dev/sda1          108544  297068543  296960000 141.6G 83 Linux
/dev/sda2       297068544 1953519615 1656451072 789.9G 83 Linux


Disk /dev/sdb: 223.58 GiB, 240057409536 bytes, 468862128 sectors
Disk model: WDC WDS240G2G0A-
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0xbd5fa220

Device     Boot     Start       End   Sectors   Size Id Type
/dev/sdb1            2048 163842047 163840000  78.1G 83 Linux
/dev/sdb2       163842048 468856831 305014784 145.5G 83 Linux

And this is my current fstab file

<file system> <mount point> <type> <options> <dump> <pass>
UUID=eea663dc-aa20-4029-a86e-7f9f8ce67bbe / ext4 defaults,discard 0 1
UUID=373e4ca3-d51e-4ffa-b546-4e8a815a5c17 /media/user00/r.all.SSD ext4 defaults 0 0
UUID=96782954-2c88-4c7a-87d1-f42396d80456 /media/user00/r.all ext4 nosuid,nodev,nofail,x-gvfs-show 0 0
UUID=20e5d70f-3982-482d-a9eb-3dfeaf8f6fd7 /media/user00/r.linux.HDD ext4 defaults 0 0
tmpfs /tmp tmpfs defaults,noatime,mode=1777 0 0

I have tried many things with fstab, but at this point I am trying out blindly...

Could you please help me, once again, to solve the fstab problem? Later, how to disable grub's menu?

THANKS!


Edit00: I followed @oldfred advice (thanks!) and later I took ownership of all partitions, so I solved the first objective. This is how my new fstab looks like:

# <file system> <mount point> <type> <options> <dump> <pass>
UUID=eea663dc-aa20-4029-a86e-7f9f8ce67bbe / ext4 defaults 0 1
UUID=96782954-2c88-4c7a-87d1-f42396d80456 /media/user00/r.all ext4 defaults,noatime 0 2
UUID=373e4ca3-d51e-4ffa-b546-4e8a815a5c17 /media/user00/r.all.SSD ext4 defaults,noatime 0 2
UUID=20e5d70f-3982-482d-a9eb-3dfeaf8f6fd7 /media/user00/r.linux.HDD ext4 defaults,noatime 0 2
tmpfs /tmp tmpfs defaults,noatime,mode=1777 0 0

The only strange thing is that now I see something like 'two instances' of the same partition in the File Manager (see the two last, both 'r.linux.HDD'):

This is how I see my partitions

and when I click in the last one at the bottom I get this message: I get this error when clicking on the last 'r.linux.HDD'

Could it be that the problem comes from the mounting options in fstab?


Edit01: I solved problem 2) as well, I edited the question to include the source of the solution.

  • Is your actual user name user00? I have not seen periods used in any examples of labels or mounts. I use CamelCase, under_score or justalabel which I try to make a bit descriptive, although mine are data, photos, and backup. I usually mount in /mnt, but /media should work. Did you give yourself ownership & permissions? Disks uses terrible mount parameters, better to use examples. discard is not recommended and noatime is for SSD. ubuntuforums.org/showthread.php?t=1983336 Create mount point, mount & edit fstab from user Morbius1 in Post # 6 - suggest using templates instead. – oldfred Jul 10 at 22:26
  • @oldfred yes the user is that one, and no problem with periods in names, I have always had them like that and it always worked -except when I screw up with other things :) Please take a look I have updated the question and there's a new error. I can live with it but it might be related to the ext4 templates I used in fstab? – terauser Jul 11 at 14:32
  • I always had the double entry with Nautilus and mount using /media. Second has a underscore at end. I now use /mnt and link folders into /home. Otherwise mount in /mnt is only accessible by drilling down(up?) from / (root).askubuntu.com/questions/1013677/… & askubuntu.com/questions/1058756/… – oldfred Jul 11 at 19:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.