1

When I use the built-in microphone without headset, everything is fine and the recording quality is high, no noise.

But when I plug in the headset (and mic), there is a high noise in my recordings. Headset is fine and tested on Windows.

I tried to lower down Headset Mic Boost value in the alsamixer but it didn't help much. I also added the following line

load-module module-echo-cancel

to the /etc/pulse/default.pa file which added a new option in the Sound settings of my system as 'echo cancelled with built-in audio analog stereo', which is fine with built-in mic but not with headset mic.

Even when I try to set the input device in the Sound settings of my system to use the built-in mic (while the headset is plugged in), the system simply ignores that and records using the headset.

I also updated the kernel from default 4.15 to 5.3, still no help.

1

I had exactly the same issue on 18.04. For me it turned out to be the headset itself. The reason why it works better on other OS (I tested on Android and it worked perfectly) is that Android/Windows have active (software) noise suppression for external microphones while Ubuntu doesn't.

Eventually I tried another (even much cheaper) headset with my Ubuntu and it worked perfectly.

Although it's possible to reduce noise by decreasing mic boost via alsamixer, an annoying background noise still exists for me, so I'm going to buy another headset.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.