1

I installed Kubuntu 20.04 yesterday and I have noticed that my CPU usage is really high. It's not high when idle but even a simple mouse moving across the sceen will raise percentages on each core.

I upgraded from from Kubuntu 18.04 and noticed some performance issues so decided to upgrade.

I can't be sure if it was a similar issue but It happened after I resized my Partition to use all the space on my SSD. I had observed some issues but didn't check deeply and I was gonna upgrade anyway so wiped the drive completely

Currently 20.04 starts fine but the performance degrades the more I use it. It's at the point where I struggle to write code in VSCode because the delay is too high and the scrolling is choppy.

In Firefox the speed of starting a window is slow and opening a new tab and completing a search takes a long time.

While programming the project's development server takes too long to refresh after saving a file and reloading windows in Firefox is too slow.

It all seem to point to the high CPU usage thing, the RAM usage is fine and I didn't install anything out of the ordinary(maybe I did that doesn't work on 20.04 well).

I had noticed speed issues right after installation but they seemed to go away after a shutdown, but it still gets slower the more I use my laptop. It's unusable after an hour usually.

Now looking for solutions I haven't found something similar yet, any help will be much appreciated.

Thanks.

Here's the htop otputs for two different sessions: enter image description here enter image description here

  • What do you have under /usr/share/code? Whatever process is under there seems to be responsible for using the majority of your resources. That directory doesn't exist in a default installation of Kubuntu - so it's likely something you installed. – Nmath Jul 10 at 18:49
  • Hi, can you please run sudo strace -C -p pid_of_vscode and interrupt it after about 10 seconds and post the output ? – Parsa Mousavi Jul 10 at 18:49
  • There's an issue reported about tsserver.js here and looks like adding the option "typescript.disableAutomaticTypeAcquisition": true to the VSCode settings mitigated the problem. – Parsa Mousavi Jul 10 at 19:00
  • does the problem happen even if you don't run VS Code? – ashvatthama Jul 10 at 19:02
  • Hey I don't believe vs code to be the sole offender here. The performnace drops will happen regardles. I looked for more solutions and turned off blur and transluscency in my desktop settings for plasma, and my system feels snappy now. To test I opened 3 different project in 3 separate vscode sessions and opened a bunch a firefox tabs. 2 tabs with 1080p videos playing. I belive turning off blur was the solution but I'll have to monitor performance again for a day or two make final judgements. – Arpit Bharti Jul 10 at 19:03
1

The solution for now was to disable Blur in plasma System settings. I will monitor my system for more perfromance issues over a day or two but the isssue seems to be gone for now.

You'll find the Blur checkbox under System Settings > WorkSpace Behaviour > Desktop Effects.

I disabled Blur and Translucency but I think it's only Blur that you'll have to target.

It remains to be explained why this issue exists and how one can continue to use Blur without performnace penalties.

Edit 1 - Update after a day of use. I turned off Baloo file indexer as well.

Good news - Performance is much better after turning off Blur. Bad news - Performance degradation still persists and my laptop slows down significantly after just an hour of use. Blur was just one of the issues, there's something else that's causing significant performance degradation.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.