0

I have done a fresh installation of Ubuntu 20.04 LTS on Surface Pro (Surface_Pro_1796) and it seems like there is some issue with battery percentage which supposed to be displayed on top bar of GNOME desktop. Did some research on this and tried the following without any success:

  1. I have no entry for battery under these directories /proc/acpi/battery or /sys/class/power_supply

    /proc/acpi/battery:
    /proc/acpi/battery

    /sys/class/power_supply:
    /sys/class/power_supply

  2. Ran acpi -b command - no output.

  3. Installed GNOME Tweaks and tried to enable batter percentage but it didn't help.

    GNOME Tweaks

  4. Installed Linux Surface kernel from this link, but it didn't help. Although it should not help, but gave a try.

I am not sure what else to try, please help.

2
0

Here are the commands I ran in sequence to install linux surface kernel:

wget -qO - https://raw.githubusercontent.com/linux-surface/linux-surface/master/pkg/keys/surface.asc | sudo apt-key add -
echo "deb [arch=amd64] https://pkg.surfacelinux.com/debian release main" | sudo tee /etc/apt/sources.list.d/linux-surface.list
sudo apt-get update
sudo apt-get install linux-headers-surface linux-image-surface linux-libc-dev-surface surface-ipts-firmware libwacom-surface
sudo apt-get install linux-surface-secureboot-mok
export GRUB_CONFIG=`sudo find /boot -name "grub.cfg"`
sudo update-grub
sudo grep 'menuentry ' $GRUB_CONFIG | cut -f 2 -d "'" | nl -v 0
sudo grub-reboot 1
sudo reboot

Reference: https://github.com/jakeday/linux-surface/issues/666

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.