I've accidentally added 'itterative' to Kile's dictionary (right click on the wrong button). Now I'd like to remove 'itterative' from the list of correct words but I can't locate the dictionary anymore (the old link in settings->configure kile ) does not link to where it used to...

Thanks in advance,

PS: I use Kile as out of the box...no special settings no-nothing


To adress Oli's answer below. Kcontrol is not in the 10.10 reps (apparently) downloading the .tar.gz version of kcontrol and install it, by typping:

cd ~/Documents/khepera
SUBDIRS="libtns_util libxfgc libkhepera kcontrol"

for i in $SUBDIRS ; do make -C $i install; done
for i in $SUBDIRS; do make -C $i clean; done
for i in $SUBDIRS; do make -C $i tgz; done

creates load-full of errors. I guess they could be solved, but it seems of an overkill just to locate Kile's dictionary. Any other ideas?

3 Answers 3


Maybe worth to try the file ~/.config/enchant/en_GB.dic. I believe that this would be the standard place for Kile to put your personal additions to the dictionary (of course replace en_GB with your relevant language/country code). It's a simple text-file, so just delete the line that contains the wrong word.


kile stores its local dictionary in /home/roger/.config/enchant/.dic for me - as Oli says it depends on what spell checker is in use.

If you're still stuck after that, you could try searching for files in your home directory with 'dict' in the name or ending in .dic

One way to do this would be with the find command at a terminal, e.g.

find . -iname '*.dic'

This will search the current directory (.) and all its subdirectories for a file ending in .dic (or .Dic : -iname is case insensitive)

  • Using the find command it a great hint, but -- provided my kile (2.9.93) is not buggy, that does not always work. My system, for example, has only one single .dic file, and that is (a) empty, (b) is not even of the right language (regarding file name), and (c) does not contain (well, since it's empy) the words I've added manually by kile. Thus, kile (at least my version) use a dictionary that has a different file ending.
    – Prof.Chaos
    Oct 25, 2020 at 0:11
  • Ah, okay. :) So in my case I was still not able to find out where the "predefined" spellbook lies, but once one adds a new word, the file .aspell.en.pws gets created (well, the name clearly reflects the language (en), and also proves that aspell is used in my case).
    – Prof.Chaos
    Oct 25, 2020 at 0:16

Depends on which spellchecker you use with Kile. AFAIK, it's very modular in this respect.

To edit it (or see what it's set to) you need kcontrol. Install it if you don't have it. Run it and then navigate to KDE Components -> Spell Checker and see what the setting is.

I think the default is ASpell (might have changed) and you can edit its dictionary by running:

nano `aspell config personal-path`
  • > i couldn't find kcontrol in the 10.10 reps. i tried to install it from the tar.gz but it's a mess (see edited question). there is nothing in nano aspell config personal-path....:((
    – user2413
    Nov 11, 2010 at 9:19
  • Old information sorry, try systemsettings instead. Are you in KDE? You shouldn't need to install it if you are but it might also not work if you're not.
    – Oli
    Nov 11, 2010 at 11:48
  • Hmm I've just read that you might actually need a full KDE environment just to set the spellchecker settings. I can barely describe how poorly designed that is if that's the case.
    – Oli
    Nov 11, 2010 at 11:50
  • note that i don't want to set the spellchecker settings. I just want to locate where the words are saved....to delete "itteration"
    – user2413
    Nov 11, 2010 at 18:07
  • @kwak I understand that but half the problem is finding which spell-checking application it uses.
    – Oli
    Nov 11, 2010 at 18:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.