I used Microsoft Teams (Linux) few months back with an organizational account. Now I want to use it with some other account. I'm currently in logged out state since I don't have access to the org account. Everytime I open, it takes me to the organizational page, and asks me to sign in. There is no Use Another account or Sign In with another account option. When you initially open, when it is sending requests to take us to the org page, there's a cancel option but that doesn't work. It makes the app unresponsive.

Now I've tried to uninstall many times with apt-remove, from software center, purge. Every time, I install, it picks up the data/cache, and tries to take me to the same org page. How can I completely reset, remove the data it is using to install with my new account.

2 Answers 2


Try removing the configuration folders for MS Teams, under ~/.config/Microsoft/Microsoft Teams and ~/.config/teams, i.e. run something like this:

rm -rf ~/.config/teams
rm -rf ~/.config/Microsoft/Microsoft\ Teams
  • 1
    Thank you! The following commands worked for me: sudo dpkg --purge teams, rm -rf ~/.config/teams, rm -rf ~/.config/Microsoft, rm -rf ~/.config/'Microsoft Teams - Preview', rm -rf ~/.config/'Unknown Organization' (I installed Teams via dpkg -i). Nov 2, 2021 at 4:53

I suceeded by deleting all folders within the path

  • Is this flatpak? Aug 5, 2021 at 9:45
  • I don't see this directory on Ubuntu 21.10 with MS Teams installed.
    – Mat D.
    Feb 4 at 8:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.