I did a clean install of Ubuntu 12.04 about three hours ago. Now I've been installing all the programs I use, etc...

However, I seem to be having a problem with a VERY laggy dash, to the point where it's almost completely unresponsive. When I open the dash and search for a program like Firefox, as I type Firefox the letters come about a second after I push the key, and the whole system starts to freeze up. When I try to highlight a program I recently used the mouse literally skips across the screen as if the screen cant keep up with it. Is anyone else having similar problems? Also, I know this is a longshot, but could any programs I have installed slow down my system? I'd love to get this sorted out, because it's a pain to have such an unresponsive menu, and I really don't want to use Gnome 3.4.

The problem is it doesn't "know" what my graphics driver is. Which is clearly a problem, how can I fix this?

enter image description here

According to Ubuntu 11.10 I had Intel Ironlake Mobile Graphics, according to this I have nothing. (Didn't have this problem in Ubuntu 11.10)

System Info:

  • Intel Core i3 CPU M370 2.40GHZ
  • 3GB of installed ram
  • 64 bit Ubuntu
  • Intel Ironlake Mobile Graphics

Anything else needed?


I have encountered similar problem - overall system performance was superb, but the moment i've hit the dash button, a major lagging started.

After installing ccsm i determined that in my case problem was connected to blur in dash. Surprisingly the solution for me was to activate KDE Compatibility -> Blur support in CCSM. You can also try to disable blur or change it to static (ubuntu unity plugin -> experimental -> dash blur).

To install CompizConfig Setting Manager type/copy into terminal:

sudo apt-get install compizconfig-settings-manager

Please, be very careful with this tool, it can really break your system.

I hope this will help with your problem. Good luck.

| improve this answer | |

This worked for me: first, install Compiz Config settings Manager (CCSM) and then, go to OpenGL and veryfy the checkbox for "Sync to vBlank" is checked.

I also enabled KDE compatibility but windows controls dissapeared in fullscreen. (so, don't enable it)

Good luck!

| improve this answer | |

Open a Terminal window (Ctrl+Alt+T) and type:

sudo apt-get install mesa-utils

After that's done, close Terminal and reopen details/sysinfo.

It's not that it doesn't recognize it. Ubuntu 12.04 just doesn't come with mesa-utils installed by default anymore.

| improve this answer | |

What version did you install? Seems the 64bit version needs more RAM.

Also, you can try Kubuntu or Xubuntu, which are more or less the same as the base Ubuntu, with different GUIs. https://wiki.ubuntu.com/PrecisePangolin/TechnicalOverview/Beta1#Kubuntu

For more feedback, we'll need your full system information please.

| improve this answer | |
  • Hey tomBryer, I found the problem, read the bottom of the post. – Midnight Apr 27 '12 at 9:13

Same problem here.

I tried enabling KDE compatibility. Indeed the lag was gone but instead the upper left window buttons were not displayed in full screen mode.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.