0

New install of Ubunutu 20.04 on a laptop. I am getting a circle with backslash symbol popping up at random times. I thought it might be a key on the keyboard going off, so I cleaned all the keys. However it is still happening. How can I check what is causing the symbol to pop up?

enter image description here

3
  • If it remains there long enough(e.g 10 seconds) run xprop | grep "wm\_name" -i from terminal and then click on that symbol and append the output to your post .It's weird.I haven't seen anything like that before. Commented Jul 9, 2020 at 13:42
  • Like this ?? i.imgur.com/vuNxFk0.png . I get that when pressing function keys on my keyboard that cannot be used in the current context. E.g. pressing "pause/play" button when no Media Player is open. Maybe some key is stuck on your laptop keyboard.
    – pLumo
    Commented Jul 9, 2020 at 13:46
  • pLumo - Yes, that is the symbol I am getting. I originally thought it was a keyboard issue, but even after cleaning it keeps coming back. I will focus on the function keys and see if it is one of those.
    – John
    Commented Jul 9, 2020 at 14:00

3 Answers 3

0

I'm facing this problem too. I'm a noob in these technological things. Please don't mind me if I'm telling something stupid.

When I diagnosed the problem using xprop | grep "wm\_name" -i, I got WM_NAME(STRING) = "mutter guard window" which told me the problem was with mutter guard window. After some googling, I reached here https://bugs.launchpad.net/ubuntu/+source/mutter/+bug/1751593 which I think is the bug. I can find many similarities. But I can't understand what they are saying.

According to my experience when I press the - key while using libre office writer, the cross appears and I am not able to type anything. The whole keyboard is stuck and the cross keeps popping.

I was able to find temporary solutions to this problem: if I hold down my dedicated mic on/off key, I can type the letters. If I release it, then the error comes again.

Also if I go to the application search bar and type something and then come back to writer, I can type letters. But the icon always pops up. Even though it occurs randomly the app search bar is not affected by the error, I can type anything. But the writer application is affected and I can't type a thing except the key that caused this problem.

According to my experience, the music play/pause, next music, previous music and music stop button caused the icon to pop up, but didn't affect the writing and I was able to type. But the - key caused the problem along with the keyboard error. Sometimes the ctrl key also causes this. Then I also found that the terminal was also affected by the keyboard error just like writer.

Also I'm dual booting with two ubuntus. Ubuntu 20.04 and ubuntu 18.04. Both OS are facing the issue. I thought it may be a hardware problem. But when I installed windows, I didn't find such error.

Then I thought that the keyboard drivers may be broken. I tried to update all the packages, but nothing improved. The shape and size of the icons are a bit different in both versions of Ubuntu. This issue was quite rare at the beginning but it became more frequent and is very irritating as I sometimes lose my control over the keyboard.

In conclusion I think that there is a problem with some software called mutter. I don't know a thing about it, can anyone help me ? I hope my info help someone.

0
0

I too had this issue. It mainly happened when I tried to play some media files. I uninstalled the vlc player and the obs software and now it seems the problem is gone. Will wait and see if it pops up again

1
  • Did you install an alternative to VLC?
    – Zanna
    Commented Jan 7, 2021 at 13:42
0

Could be that a hardware device is being triggered (on and off). This can be a loose plug or a low battery.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .