74

Just installed Ubuntu 12.04, then I did

sudo apt-get install gnome-shell

and windows have only a close button, how can I enable minimize / maximize? The old gconf-editor doesn't seem to work cause it has the three buttons in the config.

1

16 Answers 16

89

You need gnome tweak tool.

Click the Download button to install with Ubuntu Software Center:

Install via the software center


Or you can install in Terminal:

sudo apt-get update; sudo apt-get install gnome-tweak-tool

Then open Advanced Settings to change the minimize and maximize buttons.

4
  • 1
    Hmmm... could not find the specific option, I had to use ubuntu-tweak. Thanks anyway.
    – Rmano
    Commented Apr 28, 2012 at 22:27
  • 4
    @Rmano Shell > Arrangement of buttons on the titlebar [Close Only is the default setting] Commented Apr 29, 2012 at 4:05
  • 3
    FYI in Ubuntu 14.04 (Tweak Tool 3.10.4) the toggles to show Maximize and Minimize title bar buttons are in the Windows section
    – rakslice
    Commented Jul 24, 2016 at 5:19
  • 1
    Why is this not default?
    – Jan M.
    Commented Oct 2, 2017 at 20:01
44

Install dconf-editor:

sudo apt-get install dconf-tools
dconf-editor

Then navigate to:

org.gnome.shell.overrides >> button-layout

and set value to:

close,minimize,maximize: **OR** :maximize, minimize,close

Note that you might also perform this from console:

gsettings set org.gnome.shell.overrides button-layout close,minimize,maximize: 

In current versions of Gnome, you may need to use this instead:

gsettings set org.gnome.desktop.wm.preferences button-layout 'close,minimize,maximize:'
5
  • 7
    Well done vanlong. Just to add this can be done from terminal too: gsettings set org.gnome.shell.overrides button-layout close,minimize,maximize: Commented May 13, 2012 at 0:33
  • thanks Todd, things worked quite good after using the tweak you mentioned. :)
    – Ankit
    Commented Aug 27, 2012 at 2:50
  • 1
    the menu button on the window buttons is also available. I have my layout as close,minimize,maximize:menu
    – Peter
    Commented Oct 14, 2013 at 12:36
  • How do i disable it in terminal?
    – Binoy Babu
    Commented Nov 26, 2013 at 16:05
  • 2
    I had to navigate to org.gnome.desktop.wm.preferences >> button-layout to get it to work w/ dconf-editor.
    – JivanAmara
    Commented Jul 10, 2015 at 16:14
18

This is very simple guys, just type the following command in the terminal, it worked for me:

gsettings set  org.gnome.shell.overrides button-layout ':minimize,maximize,close'

In Ubuntu 17.10 (and Debian 9 Stretch) with gnome 3.26.1 command is:

gsettings set org.gnome.desktop.wm.preferences button-layout ':minimize,maximize,close'

(thanks to Ohto Nordberg's reply).

3
  • 3
    I feel this option is better than tweak-tool. It works for me. Thanks
    – bagavadhar
    Commented Jul 7, 2013 at 7:42
  • This option is very cool
    – manix
    Commented May 16, 2014 at 2:38
  • 1
    In Ubuntu 17.10 with gnome 3.26.1 command is gsettings set org.gnome.desktop.wm.preferences button-layout ':minimize,maximize,close' Commented Oct 21, 2017 at 17:38
4

I had the same problem where my Ubuntu 12.04 windows only showed the close button. I realize that it is possible to right click on the menu bar to get the missing minimize and maximize functionality but I wanted the buttons back.

I was going to install Ubuntu Tweak but found the "Advanced Settings" application. I just went to the "Shell" tab and set "Arrangement of buttons on the titlebar" from "Close Only" to "All". This restored the missing buttons onto my windows.

I hope this alternate solution helps people with the same problem.

3

I found this page when I was looking for an answer to this question. Thought some people would appreciate this information.

Here is the terminal command for those that are two lazy to open a link. Just wanted to give credit to the original contributor of this information.

gconftool -s /apps/metacity/general/button_layout -t string menu:minimize,maximize,close 
1
  • 3
    Re: links, people may not want to open links because they don't know what they land on. For askubuntu/stackoverflow and others, links without info are bad because the link may break, and the answer isn't self-contained.
    – belacqua
    Commented Jul 6, 2012 at 17:00
3

For Ubuntu 14.04+, you might need to run the following:

gsettings set org.gnome.settings-daemon.plugins.xsettings overrides "{'Gtk/DecorationLayout': <':minimize,maximize,close'>}"
1
  • Does it conflict with the gnome-tweaking-tool solution?
    – ofaurax
    Commented Dec 16, 2016 at 18:34
3

On 12.04 and 14.04, the answer given by @user161127 worked well for me (entering the following in the terminal)

gsettings set org.gnome.shell.overrides button-layout ':minimize,maximize,close'

However, on 16.04, I needed to use the path given by @JivanAmara instead:

gsettings set org.gnome.desktop.wm.preferences button-layout ':minimize,maximize,close'
1

Install ubuntu tweak.Open ubuntu tweak and go to Tweaks>Window and set "off" in Close button only . But I didn't like this type of solution though I'm sharing this solution.

1

To maximise, you can instead double-click on the window frame with the left button. To minimise, single-click the middle button on the window frame.

1
  • Middle button click does not work for me to minimize.
    – Alexey
    Commented Sep 22, 2016 at 3:52
1

I ran into this after installing Gnome 40 where I lost the Firefox Minimize and maximize buttons. Up above, user wojox gave the command line tools for the Gnome Shell. This was important because Tweaks no longer works. In his/her answer, I failed to note the difference between the leading ':' and trailing ':' in the string. The trailing ':' moves the buttons to the left side of the menubar and the leading ':' puts them on the right side.

The choice is yours.

The simple command line solution (take note of ':' placement):

This gives right buttons

gsettings set org.gnome.desktop.wm.preferences button-layout ':minimize,maximize,close'

This gives left buttons

gsettings set org.gnome.desktop.wm.preferences button-layout 'minimize,maximize,close:'

You can also use the dconf editor. Note that dconf-editor is now its own package and there is no dconf-tools.

Install dconf-editor:

sudo apt-get install dconf-editor
dconf-editor

Then navigate to:

org.gnome.desktop.wm.preferences >> button-layout

and set value to:

close,minimize,maximize: OR :maximize, minimize,close

1
  • worked on redhat +1
    – Zaman Oof
    Commented May 12, 2022 at 9:05
0

As an alternative to the buttons, you can still minimize/maximize windows by right-clicking on their titlebar and selecting the appropriate entry from the menu.

0

In Gnome tweak tool --> click on Shell in left column and then in right column for Arrangement of buttons in title bar select "all", instead of"close only".

0

The dconf-tool editor solutions described by vanlong441 and by Todd Partridge worked for me. The only thing to add is you can change the side of the buttons on the window by moving the : in the string, and change the order of the buttons by moving their names around. (Useful for personal preference and also pranking).

1
  • 1
    As you've posted this as a separate answer rather than a suggested edit (or comment), you may want to expand it further, giving explicit examples of how different strings (with the : in different places) produce different behavior. Commented Aug 17, 2012 at 23:14
0

In Ubuntu Gnome 17.04 use

dconf-editor

to open the Editor and you can find it here:

enter image description here

0

in lubuntu to show minimize maximize buttons to title bar of windows

sudo apt install `dconf-editor`
dconf-editor

ctrl+L & type to path:

/org/gnome/desktop/wm/preferences/button-layout

then use default value on and type menu:minimize,maximize,spacer,close to show minimize maximize buttons to windows

-1

To right align buttons, put the colon in the beginning:

gsettings set org.gnome.shell.overrides button-layout :minimize,maximize,close

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .