So first off, I'm using Debian sqeeze and I'm trying to make an Ubuntu 12. 04 Precise Pangolin Live USB. This is kind of a problem at the moment because debian does not have the "startup disk creator" app. So I looked through a number of debian forums and decided to try an app called unetbootin (apparently it's just about the only way I can make a live USB on Squeeze). I downloaded the iso file for 12.04, opened unetbootin and it extracted the files to the USB and everything was perfect. But when I reboot on my USB drive, the first thing on my screen is a unetbootin menu that only allows me to select "default". After I press enter it just loads a command prompt that starts with "(initramfs):" I can't figure out what I did wrong as I am a nub. Any Ideas or alternatives?

  • Did you just burn it once? Sounds like a bad burn maybe. – wojox Apr 27 '12 at 1:11
  • I tried trashing my USB and making another with the same app and .iso file. But it yielded the same result. Do you think redownloading the iso file might help? – Jiskya Apr 27 '12 at 1:15
  • Definitely worth a shot. Use a torrent maybe? There is also the dd command. – wojox Apr 27 '12 at 1:19
  • Ok, I think I'll try that. The download speed is still surprisingly slow. So it may take me awhile. – Jiskya Apr 27 '12 at 1:22
  • Yeah the servers are pretty slammed right now =) – wojox Apr 27 '12 at 1:24

You can also use dd.

First, find out what the USB drive is called with sudo fdisk -l, then unmount it, then run

sudo dd if=/path_to_iso/ubuntu-12.04-desktop-i386.iso of=/dev/sdX

the /dev/sdX part is whatever fdisk had shown, usually /dev/sdb or dev/sdc.


Here is the output of sudo fdisk -l showing my USB drive:

Disk /dev/sdc: 256 MB, 256900608 bytes
60 heads, 27 sectors/track, 309 cylinders
Units = cylinders of 1620 * 512 = 829440 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00040358

   Device Boot      Start         End      Blocks   Id  System
/dev/sdc1   *           1         310      250879    b  W95 FAT32
Partition 1 has different physical/logical endings:
     phys=(31, 59, 27) logical=(309, 43, 18)

What we need is the device name, which in this case is /dev/sdc. You may have it designated differently,for example /dev/sdb or /dev/sdd (!/dev/sda is usually the hard drive, so don't use it!).

Lets assume that the ISO I want to write to that USB drive is in the Downloads folder in my home directory.

sudo dd if=Downloads/ubuntu-12.04-desktop-i386.iso of=/dev/sdc

The command will write the contents of the ISO image to the USB device.

  • Forgive me, but I am extremely new to such commands. However, I did do it. I'm not sure if it was successful, though. Here was my output: ~$ sudo dd if=Downloads/ubuntu-12.04-desktop-i386.iso of=/dev/sdc2 [sudo] password for user: 1436248+0 records in 1436248+0 records out 735358976 bytes (735 MB) copied, 197.827 s, 3.7 MB/s ~$ I feel really dumb asking this, but what specifically did that command do? – Jiskya Apr 27 '12 at 2:11
  • If you post the output of sudo fdisk -l and the ISO location, we can tell you exactly what to type. Be careful though, the command is destructive. – mikewhatever Apr 27 '12 at 2:19
  • My USB was called, '/dev/sdc2'. But after that dd command, it's changed to '/dev/sdb2'. And the Iso locations is in my 'Downloads' Directory. – Jiskya Apr 27 '12 at 2:28
  • Right, so /dev/sdc2 is a partition, use /dev/sdc or /dev/sdb, whatever is correct at the moment. – mikewhatever Apr 27 '12 at 2:32
  • Grant, you asked what that command did. It is a bit copying utility. It wrote your cd completely to the usb, and now your usb should mount with mount /dev/sdb /mnt/temp (If /dev/sdb is your device, otherwise it might take /dev/sdb2 or something along those lines, and if /mnt/temp exists. ) It should mount as ISO9660, which is read only, and not good for a usb, if you intend on writing anything to that partition. – darkdragn Apr 27 '12 at 3:05

Umm, a dd copy is probably the worst idea for booting a livecd from a usb drive. In all seriousness, unetbootin probably just isn't keeping up with the casper scripts update, and forgot a line in the boot list. If you give unetbootin one more chance, but when it's done mount the partition it used, and go into the syslinux folder. Look for a syslinux.cfg, and look for the entry list that starts with LABEL default. On the append line, make sure it has boot=casper and cdrom-detect/try-usb=true. Without those two lines, it will not boot.

(Ex. APPEND initrd=initrd.img boot=casper cdrom-detect/try-usb=true ro splash --)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.