I have been using Slack (Desktop App) for months now, without any problem. Today, for no apparent reason, the laptop (HP Envy) froze and since then Slack is not working anymore. It seems to try to launch, but then nothing. Any ideas?

  • 4
    Also seeing this - having to resort to the browser version for now.
    – Ross
    Commented Jul 8, 2020 at 12:04
  • 2
    Looks like 4.7.0 was released yesterday and slack don't allow you to install an older revision. So until the next release is out, the web version seems to be the only choice.
    – Ross
    Commented Jul 8, 2020 at 12:22
  • 2
    snaps are updates are revertable. So if you have had a working slack that just suddenly died on you, then See leonexis' answer below for how to easily revert the update of slack.
    – KlausCPH
    Commented Jul 11, 2020 at 22:04
  • I installed in September and updated... a few days ago, and this is still a problem. Commented Nov 19, 2020 at 5:12
  • it seams like it happened again (nov 2021)
    – Mx.Wolf
    Commented Nov 27, 2021 at 15:12

7 Answers 7


Looks like there is a confirmed issue with the snap package.

We’re very sorry for the trouble there. We are experiencing some difficulties with the Slack Snap package. Our team is working hard to resolve the issue as quickly as possible. For now, you can access Slack via a browser or on our Direct Download version: https://slack.com/intl/en-gb/downloads/linux?eu_nc=1

Source: https://twitter.com/SlackHQ/status/1280808281989152771

A fix should be available in the next snap slack package release.

  • 3
    If you haven't already tried reinstalling the Slack snap, leonexis' answer could save you a lot of trouble.
    – Lambart
    Commented Jul 10, 2020 at 13:46
  • I've have had the same experience and reinstalling slack with their deb package hoping this would work but recently I also had problems starting eclipse on ubuntu 20.04 I attempt to reinstall it cause I thought restoration to ssd have something to do with it but it still did not work and a couple of days later it started working again, I'm new to snap cause I've using apt since so I wonder if snap have something to do with this issue? there are also other packages installed here with snap and won't open as well Commented Jul 15, 2020 at 22:43
  • It could be coincidental, either way until they do a new release on 20.04, install 4.7.0 via the deb package for it to work.
    – Ross
    Commented Jul 17, 2020 at 7:49
  • I had to re-login, but reinstalling the snap package seems to work - reinstall snap package answer: askubuntu.com/a/1231238/277898
    – jave.web
    Commented Aug 7, 2023 at 9:09

I fixed this problem by removing the snap and installing the deb instead. https://slack.com/downloads/linux

  • 2
    This worked for me on Ubuntu 20.04. Thank you!
    – Zion
    Commented Jul 15, 2020 at 2:21
  • Might be more complete answer with what you did to remove snap. Commented Nov 19, 2020 at 5:14
  • 3
    Remove the snap version with: sudo snap remove slack Commented Apr 20, 2021 at 16:54

Slack 4.7.0 seems to be the issue. Contrary to one of the comments above, it is entirely possible to install an older version, which is one of the key features of Snaps...

To revert back to the previous version of Slack, use sudo snap revert slack:

$ snap list --all slack
Name   Version  Rev  Tracking       Publisher  Notes
slack  4.4.3    24   latest/stable  slack✓     disabled,classic
slack  4.7.0    25   latest/stable  slack✓     classic

$ sudo snap refresh slack
snap "slack" has no updates available

$ sudo snap revert slack
slack reverted to 4.4.3

Try to update again when there is a version above 4.7.0. This resolved my issue on Ubuntu 18.04 which exhibited the same issue (try to launch then immediately closes).

  • 2
    Thanks, but what if 4.4.3 is not in the list? Mine lists 3.3.1, which when run, demands an upgrade to 4.7.0. Commented Jul 9, 2020 at 13:57
  • 2
    I tried re-installing it before learning of this command, so I don't have this option either. There doesn't seem to be a way to install older versions of slack via snap (snap supports that, but slack only publishes the latest version...)
    – Eloff
    Commented Jul 10, 2020 at 13:08
  • 1
    I can confirm with worked for me on 18.04. Would it be best to post a new question asking 18.04 and offering this as an answer?
    – Andres
    Commented Jul 11, 2020 at 2:18
  • Unfortunately, I had already tried reinstalling Slack. I will keep this in mind next time!
    – Camila
    Commented Jul 14, 2020 at 14:27
  • 2
    I'm using Ubuntu 20.04. Unfortunately, version 4.4.3 is not listed when running this command. David Barratt's suggestion to download the .deb worked though.
    – Zion
    Commented Jul 15, 2020 at 2:24

After recent upgrade to Ubuntu 20.04 slack would not start - version 4.10.0. Reverting to 4.9.1 did not help.

I removed via the following command

sudo snap remove slack

then reinstalled via

sudo snap install slack --classic

All good now (4.10.0 was reinstalled).

Thanks for the above helpful snap commands!


I'm running Snap 4.17.2 64-bit on Ubuntu 20.

Help > Troubleshooting > Clear Cache and Restart fixed the problem for me.

  • 1
    Thank you, it helped me. It seems that Slack data on my computer was corrupted. I actually did snap remove --purge slack && snap install slack, but I now realize I could have used this feature instead (or the "Reset App Data" probably).
    – Tim
    Commented May 23, 2022 at 8:00

Installing the latest version (4.7.0) directly through .deb worked for me on Ubuntu 20.04:

wget https://downloads.slack-edge.com/linux_releases/slack-desktop-4.7.0-amd64.deb
sudo dpkg -i slack-desktop-4.7.0-amd64.deb
rm slack-desktop-4.7.0-amd64.deb

I would prefer to install through Snap so I'm going to keep an update on the Snapcraft release to see when it hits the next version. Until then, this is a good work-around.


Following the answer from leonexis, I used the following to get the older version of slack -- I too had reinstalled and thus could not use the nifty slack revert command...

wget https://downloads.slack-edge.com/linux_releases/slack-desktop-4.3.2-amd64.deb

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .