I just installed the pgadmin3 package on an up-to-date Ubuntu 12.04 installation.

I thought pgadmin was repeatedly crashing, because I'd switch to another window and then when I used the application switcher (Alt-Tab), pgadmin wasn't listed, and then when I clicked the launcher icon, the program started all over again.

It took me a while to realize that I had multiple instances of pgadmin3 running!

I'm guessing this problem is caused by bug(s) in pgadmin3 or something wrong in the launcher setup, but I looked at the pgadmin3.desktop file and compared it the .desktop file for an app that works fine and saw nothing suspicious. I realize that pgadmin3 is not a Gnome app, but it is a GUI app included with Ubuntu and it should work with the default desktop (Unity, that is).

Thankfully, every instance of pgadmin does show up in the "window spread" (Super-W) view.

I guess for now I will have to adapt my habits to use Super-W instead of Alt-Tab (or clicking the active launcher icon).

Any ideas? Where should I file a bug? Under pgadmin3, Unity, or...?

  • Well, this problem (with pgadmin3) magically went away for me in the last few days. I asked the question after upgrading to 12.04 LTS final but it's possible I had not restarted the machine before "confirming" the problem. I would delete the question but it got a couple up-votes so maybe this is still an issue for some applications and/or users. I'm sure pgadmin isn't the only app that's had this problem, whatever caused it...
    – Lambart
    May 3, 2012 at 19:06
  • Now the same problem is happening but with Pidgin instant messenger. It was working fine this morning (as well as it works with Unity, anyway) and now it's broken. It doesn't appear in the switcher and the launcher icon has no indication that it's running. Maybe it's just a problem with applications with "P" and "G" in the name? :)
    – Lambart
    May 8, 2012 at 17:40
  • One I didn't mention about my problem with Pidgin is that I had just removed and re-installed it (to try and fix an unrelated problem) before I had the launcher icon/switcher problem. So it was newly installed. Rebooting solved the issue.
    – Lambart
    May 9, 2012 at 18:40

2 Answers 2


Short but annoying answer: reboot (or perhaps just log out) after installing new applications until this bug is fixed.

Longer answer:

I just installed Chromium today (nothing wrong with Firefox but I also need to use Chromium for work) and was frustrated because I couldn't get it to maximize on my second monitor! I could move it to the second monitor but if I hit the window-maximize button, it jumped to the main monitor (maximized). Because of the problems I described above (with PG Admin and Pidgin).

I glanced at the launcher icon and saw that it didn't indicate that Chromium was running. Clicking the launcher opened a new Chromium window. On a whim I restarted the computer (maybe could have just logged out), and... both problems are solved! Chromium maximizes, and launcher knows it's running. I expect that it wouldn't have appeared in the switcher either, but forgot to try that.

I left the Windows world 12 years ago and haven't looked back. One thing that's been nice with Linux is rarely having to reboot the computer to "fix" anything. But today it feels like I'm having a bad Windows flashback. Still trying to be patient with Unity.

So it appears that there is a bug that only occurs for newly-installed programs. I don't know if it's something in the installer scripts or if Unity can be blamed for not discovering them, but I never had this problem with classic Gnome. I will follow up on this page once I install another GUI app and report whether this happens with every new app or just certain ones. I should probably also file a bug but I have a feeling it must have already been reported... if only I could find the right search terms.

  • I think this bug, which was recently fixed, might be related to this problem. It was just pushed out in Ubuntu 12.04 updates. Hopefully this will solve my problems: bugs.launchpad.net/bamf/+bug/976642
    – Lambart
    Jul 10, 2012 at 19:54

Try opening up the .desktop file and look for a line that says Type=Application. If that line isn't there, add it, then save the file. You may need to refresh unity with unity --replace. Good luck!

  • I will try unity --replace next time. The .desktop files are fine (which is why they eventually work, after restarting the system). I think the problem is that Unity isn't properly recognizing the apps at install time.
    – Lambart
    May 10, 2012 at 20:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .