0

I am facing a weird problem in Ubuntu 20.04 with kernel version 5.4.0-40. I have got a Wi-Fi adapter from Realtek for connecting my PC to the internet. From this answer, I have followed the instructions and downloaded and installed the driver from Github. It worked well for a few months, but since a few days I am facing the issue.

Ubuntu is detecting the presence of a Wi-Fi adapter, but whenever I am going to WiFi settings to connect to a network, the settings page says No WiFi adapter found:
enter image description here I can understand that Ubuntu is detecting the adapter because WiFi option is appearing in the system tray when I connect the adapter:
enter image description here

I have also tried connecting to WiFi network from the command line with iwconfig. Here is the output of the command:
enter image description here When I try to connect to a WiFi network with the iwconfig wlx00e0202c7613 essid <SSID> key <PASSWORD> command, I am getting this error: enter image description here

What is the problem and how to fix this issue? I do not know much about networking in Linux, so please ask if more information is required.

Edit: I have removed some packages a few days ago thinking them to be unnecessary. I suspect that has caused the issue. Can anyone please give a list of the necessary packages for Ubuntu, or the packages which comes preinstalled with Ubuntu 20.04?

Output of lspci -kv | grep 'Ethernet\|Network' -A 6:

02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 0c)
    Subsystem: Gigabyte Technology Co., Ltd Onboard Ethernet
    Flags: bus master, fast devsel, latency 0, IRQ 16
    I/O ports at e000 [size=256]
    Memory at f7c00000 (64-bit, non-prefetchable) [size=4K]
    Memory at f0000000 (64-bit, prefetchable) [size=16K]
    Capabilities: [40] Power Management version 3
    Capabilities: [50] MSI: Enable- Count=1/1 Maskable- 64bit+
  • When WiFi stopped working, did it happen after you upgraded your kernel? – avisitoritseems Jul 20 at 23:17
  • And if possible, can you show the output of lspci -kv | grep 'Ethernet\|Network' -A 6? – avisitoritseems Jul 21 at 1:51
  • @avisitoritseems Yes, it happened after upgrading my kernel from 5.4.0-39 to 40. For the output, please see my edits. – Puspam Jul 21 at 6:15
  • Every time you update or change your kernel in Ubuntu, it is usually required for you to run dkms to reinstall external modules. You can reinstall the module you linked with sudo dkms install rtl8188fu/1.0 then sudo modprobe -v rtl8188fu to load it – avisitoritseems Jul 21 at 17:44
  • Thanks for the suggestion, but it didn't work. I have also tried to remove and then rebuild the driver, but still no luck. – Puspam Jul 23 at 14:07
0

I have solved the problem. I just had to edit the file /etc/NetworkManager/NetworkManager.conf.
In that file, somehow my WiFi adapter got set to unmanaged. The file contents were as follows:

[main]
plugins=ifupdown,keyfile

[ifupdown]
managed=true

[device]
wifi.scan-rand-mac-address=no



[keyfile]
unmanaged-devices=interface-name:wlx00e0202c7613

So, I just removed the last two lines which specify the unmanaged devices list. After that, the adapter got detected and now I can scan for and connect to WiFi networks :)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.