1

OS: Ubuntu 20.04

Each time that I start the pc and log into my account the ethernet Connection doesn't work and the ethernet icon does not appear in the top-bar.

cat /etc/netplan/*.yaml output:

# Let NetworkManager manage all devices on this system
network:
  version: 2
  renderer: NetworkManager

if I run sudo lshw -C network i get the following output

  *-network DISABLED        
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: enp3s0
       version: 0c
       serial: e0:3f:49:46:0b:53
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical
       configuration: broadcast=yes driver=r8169 latency=0 link=no multicast=yes
       resources: irq:18 ioport:d000(size=256) memory:f7100000-f7100fff memory:f2100000-f2103fff

I saw that i had to put it's logical name inside the /etc/network/interfaces

auto enp3s0
iface enp3s0 inet dhcp

toggle the managed field inside /etc/NetworkManager/NetworkManager.conf

[ifupdown]
managed=true

and reboot.

I did so but didn't work. The only way that is currenty working is to run sudo dhclient but i have to run it at each reboot. What can i try for a perma solution?

11
  • The internet icon doesn't appear because you've changed /etc/network/interfaces. – Pilot6 Jul 7 '20 at 14:13
  • It wasn't appearing also before changing it, it was an empty file – Mat.C Jul 7 '20 at 14:14
  • It shouldn't be an empty file either. – Pilot6 Jul 7 '20 at 14:16
  • if you click on the ethernet conection and go to settings for wired connection is there a tab that say connect automatic is this on or off. – trond hansen Jul 7 '20 at 14:17
  • I have nothing about ethernet connection in the settings, only wifi – Mat.C Jul 7 '20 at 15:25
5

I had to follow the steps given in this answer

Basically run these two commands

sudo touch /etc/NetworkManager/conf.d/10-globally-managed-devices.conf
sudo systemctl restart NetworkManager

0

Edit /etc/network/interfaces and post there ONLY

# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

The network device will be controlled by Network Manager, and you'll have the settings back.

When you add entries to this files, it disables Network Manager.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.