My previous question was closed, but the duplicate it pointed to didn't solve the issue.

I have recently updated my laptop from 17.10 to 20.04. One of the features I liked was that quite easily I was able to display on my menu bar the time with day, date, and time including seconds. I have tried to install GNOME Shell Extensions so I can install e.g. Clock Override. But, having followed numerous guides, and installed features in my browser, I can go to extensions.gnome.org, but I get an error

Unable to locate GNOME Shell settings or version. Make sure it is installed and running.

I cannot find a way around this. I have also installed "Configure GNOME Shell Extensions", and this loads with the message "Something's gone wrong".

I also installed GNOME Tweaks, and cannot see the Extensions appear there either.

However, if in Terminal, typing gnome-shell-extension-tool --help does provide evidence it is installed.

So, as that was hopeless, I tried looking at this from another perspective, and saw that dconf would allow me to change the settings - possibly to the ones I want (although access to a format string would be perfect). So, I found some settings, changed them, and nothing happened. I am at a loss as to how to effect something that was quite easy to do in 17.10, and seems impossible in 20.04. Having been pointed to another question about GNOME 3, I read that article and the following was found:

gsettings set org.gnome.desktop.interface clock-show-seconds true

was already set to true - confirmed both using dconf and gsettings get.

I also looked at the Tweak tool, but that didn't have the settings suggested.

So, in summary, my clock currently shows e.g. "09:55". What I would like (as I did on 17.10), was to have it show e.g. "Tues, 6 July 09:55". Sadly, this I cannot seem to achieve!

Some info:

  • chrome-gnome-shell was installed without making any difference on Sunday (I think!) - following a guide on getting the clock to work.

  • echo $XDG_CURRENT_DESKTOP gave


    and echo $XDG_SESSION_DESKTOP gave


Just to be clear (and my apologies if I have caused confusion), but the installation of 20.04 was as though the hard disk had been reformatted. There was no traces of any other OS on the installation so this is as pure an installation as one could get.

Is the final suggestion to create a new user and see what happens? If so, I can try that after the end of the day.

Also, I have another laptop with 20.04 and I can try the process on there.

  • Also try temporarily creating a new account and try the normal procedure there (Gnome Tweaks or dconf editor). If that works, you know it is not a system wide issue, but an issue with the config of your current account. Edit your question and clearly indicate this is a fresh install of 20.04. ('update" may be misunderstood as an upgrade over a previous version) – vanadium Jul 7 '20 at 9:51
  • Many thanks for your help. I tried on my other laptop (which also used Metacity) and it has the same issues. I tried logging in using Ubuntu on Wayland, and that showed the clock as I had configured. So, this is an issue with flashback/ metacity. If it wasn't clear before, I can see using e.g. dconf/ gsettings and maybe the Tweak tool (i.e. every method I can think of) that the clock has the day, date and seconds enabled - yet it doesn't happen. And chrome-gnome-shell is installed (as of c. Sunday!). Many thanks for all your help. – DinghySailor Jul 8 '20 at 7:27
  • Sadly, I am no closer to a solution, so I cannot indicate it as solved. All we know now is that there seems to be a problem with flashback/ metacity (which we knew) that isn't on Wayland - but that doesn't allow me to have the feature that the system says I have - or that I would like! Sorry!! Any other ideas to move this forwards? Many thanks, – DinghySailor Jul 8 '20 at 16:54
  • @DinghySailor did you try commands from my answer? It should work unless you have customized applets and are not using default panel configuration. – muktupavels Jul 10 '20 at 5:38
  • 1
    @DinghySailor I don't understand what your issue is now. As it's finally established you're in a GNOME Flashback session (unintentionally, I presume) as opposed standard a GNOME Shell session. There is no "issue with flashback / metacity"; you're trying to apply a solution for GNOME Shell which unsurprisingly doesn't work in Flashback. One of the answers explains this and tells you how to switch to a standard GNOME session. Another one tells you how to toggle various date-time options on in a Flashback session itself. What else is missing now? – pomsky Jul 12 '20 at 11:12
gsettings set com.canonical.indicator.datetime show-day true
gsettings set com.canonical.indicator.datetime show-date true
gsettings set com.canonical.indicator.datetime show-seconds true
  • 1
    Also useful: gsettings set com.canonical.indicator.datetime time-format 24-hour – pts Oct 13 '20 at 14:29

The solutions you have tried are applicable for the standard GNOME 3 session, whereas from the outputs of the echo $XDG_CURRENT_DESKTOP and echo $XDG_SESSION_DESKTOP it is clear that you're in a GNOME Flashback session. So solutions are not applicable.

To switch back to a standard GNOME 3, reboot your computer. Then at the GDM login screen, you should find a cogwheel (⚙️) at the bottom right corner. If you click on the cogwheel you should find an 'Ubuntu' (and 'Ubuntu on Wayland') option. select it and then log in.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.