I am using this windows client to access Ubuntu:

enter image description here

When I reconnect, clipboard usually works, but some time later it usually stop working. But clipboard I mean copying in windows and pasting in Windows. This is version of my server: Are there any related known issues? I was not able to google anything, but this happens regularly and reproduces for other developers in my team.

  • Have you tried asking them? They have a mailing list. That may be the best source for help.
    – KGIII
    Jul 23, 2020 at 20:52

6 Answers 6


I'm Stefan Baur, X2Go's Community Manager.

This is actually a long-standing bug with X2Go that is particularly hard to track down, as the conditions to trigger it are not quite clear yet.

It seems you had posted a bounty for this issue, but it was removed again? I'm posting here to let you know we're aware of the issue and are currently looking for sponsors to get it resolved. Some have already stepped up.

If you want to chip in (again), let us know by subscribing to the X2Go-User Mailing list (https://lists.x2go.org/listinfo/x2go-user - note that this is a double-opt-in list, you need to subscribe and click the confirmation link in the E-Mail sent to you before you are able to post) and posting a message with a Subject like "X2Go Clipboard Bounty" or similar - that should catch my attention.

  • If you seek community support, why don't u upload sources and bug base to github? These cryptic mail lists are too inconvenient.
    – stiv
    Oct 16, 2020 at 15:56
  • 1
    @stiv If only it would be that easy. Due to a legal issue (trademark), we are required to host the project (and thus, its source) in Germany. So github is out of the question for us. We currently have our own git repo on code.x2go.org, but it doesn't support pull requests. We're moving to a self-hosted gitlab instance, but due to a lack of manpower in that area, this will still take some time. The good news is that at our last community event, we were able to track down some clipboard issues, and while the fix hasn't made it to the official nightly builds yet, we have something coming up. Oct 17, 2020 at 19:41
  • @stiv also, if you can live with Copy-Paste working purely "the Windows way" (iow, no automatic clipboard fill on highlighting - instead, Ctrl-C is required every time, no paste on middle mouse click), try this workaround: 1. Open X2GoClient 2. Go to Options/Settings/X.Org Server Settings 3. Select "use integrated X Server" 4. Check the box “do not use PRIMARY clipboard” 5. Close X2GoClient 6. run TaskManager, search for x2goclient (to make sure you didn't minimize it instead) 7. Start X2GoClient again 8. Run your X2Go session Sorry for the lack of formatting, BTW. Oct 17, 2020 at 19:55
  • I think the problem is not with hosting codebase, but with bad interface of mailing lists, which should be abandomned in favour of github account. People can't leave their feedback on these lists, its too complicated.
    – stiv
    Nov 24, 2020 at 16:37
  • LikeI said, we're working on transitioning to a self-hosted gitlab instance - no github, for the reasons explained above. But a similar workflow with a web-based issue tracker etc. Since at the moment, it's all a volunteer effort, it will take some time. Sponsoring is one way to accelerate the process, volunteering is another. Nov 25, 2020 at 17:09

I am facing the same issue. I am running PyCharm on Ubuntu (Server) and notepad++ on Windows (Client) and want to copy between them.

To me it seems that the clipboard gets locked by x2go if something is in it on the Ubuntu side.

The following workarounds often do the job if copy&paste is not working any more:

  • Windows to Windows : (Works almost 100%) Cut any text in Ubuntu and paste in Ubuntu. Now, you can go to Windows and cut and paste whatever you like. This works for me.

  • Windows to Ubuntu: Close Application (Pycharm) and x2go and reconnect - but who wants to that all the time :-(

  • I can confirm the workaround for making Windows to Windows copy and paste work again works. I believe Johannes is on to something here, this bug might be triggered when the Ubuntu side has text already selected or in clipboard, and you try to copy something on the Windows side.. Jan 13, 2021 at 10:37

Setting "Do not use primary clipboard" in x2go client settings (and then restarting client) worked for me

  • Thanks! Now the "copy by select" won't work from linux to windows, but the Ctrl+Shift+C works flawlessly. No hiccups since I turned this option on.
    – Philipp F
    Sep 29, 2021 at 6:43

make sure that the clipboard setting is not commented out in: /etc/x2go/x2goagent.options

for me it usually works, but I've noticed a size limitation: when I try to copy large text from Ubuntu I cannot paste it in Windows... is this size limit configurable?


I manage to copy a figure out when I set "Copy and paste from client to server" in "Clipboard mode" in "Session preferences".


If session preference is already set to bi-directorial and it does not work. Then close the x2go session. Set preference to only one way. Start x2do. Try it out. close x2go. Set preference to bi directorial. Start x2go and try both ways. For me copy/paste started working both ways.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .