I upgraded to Kubuntu 12.04 today. I noticed some of my desktop effects were not working, like Wobbly Windows, and a couple others. So I went into Jockey to see if there were NVidia drivers that I needed, but oddly, there were none listed at all. So I went and installed NVidia drivers from their website. Now I cannot get to a login screen, and when I go to tty[1-6] and try "startx", I get an odd message stating that I may have to downgrade my X server, and that a GLX thing cannot be loaded because my X version does not support that.

  • The first time I installed NVidia drivers from the terminal, there were many errors saying that files cannot be copied. After that when I tried to reinstall the graphics drivers I got no errors.
  • There are no drivers listed in Jockey.
  • My graphics card: GeForce FX 5200 (aka NV34)
  • Driver version 173.
  • Trying to install nvidia-173 using APT results in an error saying that there are unmet and uninstallable dependencies.

My questions are: are these drivers unnecessary because of Ubuntu's move from DRM? Did I do the wrong thing? If so, how do I remove the drivers from my system, or how do I install them correctly?


nvidia-96 and nvidia-173 uninstallable on Precise


I have same problem too, but we need wait for NEW driver from Nvidia.

  • Any word or evidence at all as to when or if that's happening? – Richard Apr 27 '12 at 16:12
  • @searchfgold6789 no way to tell. nVidia has to release the drivers, they're pretty hush-hush about when they release though. – Thomas Ward Jun 25 '12 at 18:57

If you have a Nvidia card you should use the proper proprietary drivers for it whenever possible.

Reasons include the fact that the card was made to be used with specific drivers and when you use the card manufacturers drivers the card will preform at better efficiency with less errors which in turn means a longer life for your card and machine .... Basically while the nouveau drivers will function your card will run hotter and slower effectively reducing its life and performance .....

I have a nvidia card i go to system settings and additional drivers and make sure the driver marked (version current) [Recommended] is enabled

reason being i tried the other one and compiz crashed constantly now that I'm using the right one I have no issues I have Atlantis fish tank enabled with rotating cube and water effects on dual monitors and my nvidia card handles it all at just under 60 C and only 40% capacity nouveau cannot do this its not good for your hardware to use other than whats made for it.

If you have problems finding the correct driver you will just need to visit nvidia and give them your card number and type..... They likely have a system scanner but i doubt it will work for linux..... Their drivers are still the best out there

I am confident that Nouveau will work out the bugs and will be usable in the next year right now its just inefficient and unstable I wouldnt use it

hope that helps .....cheers

  • Thank you, that was my line of thinking, therefore I gave that answer a vote up; see my comment on the first poster's answer. However Jockey (aka Additional Drivers) still does not find my drivers, and installing them the way you suggested does not get me to a desktop. – Richard Apr 27 '12 at 0:15
  • 1
    ohhhh so yer at prompt ....here ya go sudo apt-add-repository ppa:ubuntu-x-swat/x-updates && sudo apt-get update && sudo ap-get upgrade && sudo apt-get install nvidia-current – dewb Apr 27 '12 at 0:34
  • ehh that made the system unbootable, went into recovery mode and purged nvidia-173, and I'm back to the sate I was in when typing that question. – Richard Apr 27 '12 at 16:11

Did you try using the Properiety Drivers from the system settings? If one is available you should be able to install an NVIDIA driver such as "NVIDIA X Server Settings"?

  • 1
    I did look to see if there were any drivers available and there were none on the list, as I stated in my original question. – Richard Apr 26 '12 at 23:41

Unless you need gaming on your Linux machine I would go with the open source driver.

Try to uninstall the driver you took from nvidia (it should have an uninstall feature), then you can reinstall the new driver (or the nvidia driver that comes with Ubuntu if one is available):

Open the Terminal ctrl + alt + t and type in this command:


follow the instructions presented

Note: typing jockey-text -h will show you the options available.

  • Thank you, but I do need gaming on this desktop, and fully featured smooth desktop effects even if it means I lose some stability from that shader bug that 173 has. I will try your suggestion and hopefully it will get me to a desktop ^.^ – Richard Apr 26 '12 at 23:20
  • I tried your suggestion. jockey-text started with a display-related error but did not find any drivers. – Richard Apr 26 '12 at 23:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.