4

I want to delete the "Desktop Icons" Gnome extension in Ubuntu 19.10. How may I do that without that red delete button?

enter image description here

4

The ones where you do not see the option to remove are extensions that are installed system wide, as opposed to these you install from the browser.

  • Locally installed extensions: Gnome Shell extensions that you install from the Gnome Shell extensions website are installed in your account (actually in the folder ~/.local/share/gnome-shell/extensions). You can remove this extension from the Gnome Shell extensions website by clicking the red-with-white-cross "Delete" button.
  • System wide installed extensions: Some Gnome Shell extensions are installed system wide (in the folder /usr/share/gnome-shell/extensions) as a .deb package manager, just like any regular application. These cannot be removed by the user from the website. They can only be removed by a user who has administrator privileges, using Software Center, or using a graphical package such as Synaptic, or using the apt remove command in the terminal.

So for example, you could remove the Desktop icons extension with the command

sudo apt remove gnome-shell-extensions-desktop-icons

(note I do not recommend uninstalling this extension: it is part of Ubuntu desktop. Just disable it - the effect is the same, and the extension hardly takes up any space on the disk.)

You can see all available system-wide gnome-shell extensions with the command

apt search gnome-shell-extension

Ubuntu 20.04 users

Starting from Ubuntu 20.04, there is a "dedicated" app for extensions, which functions pretty much the same as the Extensions tab in Gnome Tweak, except you can uninstall locally installed extensions (that feature one day was removed from Gnome Tweaks).

  • Locally installed extensions (from the website) appear in the top section under "Manually Installed". These extensions can also be uninstalled from within the app.
  • System wide extensions are listed below, under the "Build-in" section.
| improve this answer | |
1

Please note that there is an accepted answer in this question, because is FAR BETTER than this one. Please read all comments before proceeding.

I've just found an answer here, so just in case it helps someone with this very annoying little issue, I'll post it here:

The button does not appear because is a system-side extension. So when you try to manually delete it from here (user side extensions)..

~/.local/share/gnome-shell/extensions

...It just won't appear listed there.

You need to go into the system-side folder:

/usr/share/gnome-shell/extensions
| improve this answer | |
  • 2
    Not the good answer! These extensions are installed using apt packages. The proper way is to remove them using sudo apt remove or using Software center. Please update your answer. It is fine to mention where these extensions live, but it is not fine to advice deleting them: you end up with an inconsistent apt package system! – vanadium Jul 6 at 16:27
  • Oh I see! Thanks for the clarification!! I did not know this. In that case, how may I remove the extension? I mean, given that I could not use the UI, how may I do that from the terminal? I assume I need to add the name of the extension after remove? Again, thanks for the clarification!! – Rosamunda Jul 6 at 17:03
  • 2
    Here you go. I added some extra information for when you move to 20.04. 19.10 will be EOL pretty soon, – vanadium Jul 6 at 18:27
  • 1
    You're welcome! You could delete your own answer (there is an option under your answer): good info there (thanks!), but is is never advised to manually delete system files for regular users. – vanadium Jul 6 at 19:25
  • 1
    I don't recommend deleting this answer. It's not advisable to delete system files willy-nilly, but it's still a valid answer. Consider adding a warning to the answer. Also instead of deleting altogether, one step better solution would be to rename the extension folder, so that if anything goes wrong you can restore it again by renaming it. – pomsky Jul 6 at 19:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.