1

I recently upgraded from Ubuntu Studio 16.04 to Kubuntu 20.04 (installed fresh on new partition), and after this the two thumb buttons on my GMX 5 mouse stopped working. When using Ubuntu 16.04 I never had to do anything to get them working, just plugged in the mouse and the buttons were immediately recognized in xev and I could use xbindkeys to set them to desired keyboard presses. When I run xev in 20.04 and press the thumb buttons I only get this:

KeymapNotify event, serial 39, synthetic NO, window 0x0,
keys:  4294967236 0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   
       0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0

Instead of the expected output when pressing a mouse button.

When running xinput I get this, I find it curious that the mouse seem to have two entries under pointer and three under keyboard:

⎡ Virtual core pointer                          id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ E-Signal USB Gaming Mouse                 id=8    [slave  pointer  (2)]
⎜   ↳ E-Signal USB Gaming Mouse Consumer Control        id=11   [slave  pointer  (2)]
⎣ Virtual core keyboard                         id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=7    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ E-Signal USB Gaming Mouse Keyboard        id=9    [slave  keyboard (3)]
    ↳ E-Signal USB Gaming Mouse System Control  id=10   [slave  keyboard (3)]
    ↳ Eee PC WMI hotkeys                        id=12   [slave  keyboard (3)]
    ↳ E-Signal USB Gaming Mouse Consumer Control        id=14   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=13   [slave  keyboard (3)]

When running xinput query-state for the two pointer id:s 8 and 11 I get different results, 8 reports buttons 1-9, while id 11 only reports 7 buttons, I wonder if this has any significance?

What can I do to get the extra mouse buttons detected again?

0

Problem is solved now, I was thrown off by the output from the thumbbuttons in xev being different from the regular buttons. When testing in 16.04 I discovered that it was supposed to look that way in xev. The actual problem was that I thought I had installed xdotool but actually hadn't, causing xbindkeys to not be able to translate buttons to keypresses.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.