1

I have been trying to make this work for 3 days straight right now. I just installed Ubuntu on a USB (San Disk Cruzer Glide 32GB) on Windows 10. I know that the installation is correct since my brother tried it on his computer and it works, and he also has Windows 10. Here are some other specs about my computer:

Motherboard: msi tomahawk b350  
CPU: AMD Ryzen 2400g

I have installed all the drivers. My boot priority has the USB drive first. The hard drive that Ubuntu is getting installed on is my C drive with 300 GB unallocated space and partitioned.

I can't screenshot the startup steps, but I can do my best to explain it. When I turn on my computer, the first thing that shows up is a black screen with a few options:

Ubuntu  
Ubuntu (safe graphics)  
a few others I didn't think were important...

I click the first option (Ubuntu), and then it takes me to a loading screen where it keeps on saying connection timed out. Then after a while it takes me to a screen, where it shows my motherboards regular startup screen but smaller, text that says "Ubuntu" on the bottom, and then a circle going round and round. I waited for a while, and eventually the loading circle froze itself. I went to sleep and when I woke up it was still at the same screen.

I think that's all the information you need, if there is anything else please tell me in the comments.

  • 3
    It seems like you are saying that you created a LiveUSB installer that works properly on your brother's hardware, but fails to boot on your hardware. Is that accurate? – user535733 Jul 6 at 0:35
  • Yes, that is correct. – nishantc1527 Jul 6 at 0:45
  • Does your motherboard use UEFI or BIOS? Could it be a boot partition problem (GPT/MBR)? – GChuf Jul 10 at 13:54
  • @hextech The setting show "Legacy + UEFI," so I guess it does however I am not completely sure. – nishantc1527 Jul 11 at 5:10
  • 1
    While at the last screen you see, press Ctrl+Alt+F1 or Ctrl+Alt+F2. Report back what you get. You can take pictures with a cell phone and post here. – sancho.s ReinstateMonicaCellio Jul 14 at 8:26
1

If you are sure that the USB is a live installation media, than you can try spamming the boot menu button, which seems to be the f11 key while the computer is booting up. This will prompt you for a boot menu to select the boot device you'd like to use. At that point choose USB or the San Disk Cruzer Glide 32GB and let the installation continue. Once you have installed Ubuntu, make sure that you take out the installation media (USB) BEFORE starting the computer again. Than you should boot into the correct OS!

| improve this answer | |
  • I tried this, but unfortunately it doesn't work. It produces that same way as I mentioned above. – nishantc1527 Jul 14 at 6:43
1

It seems to me that your computer gets stuck when starting X. The startup image of your motherboard with the circle means the framebuffer boot is working (you can press Esc during that loading screen to see what's happening) but likely gets stuck when the display manager is starting. What is your current GPU? My suggestion would be to try starting with safe graphics and if you manage to boot, install the appropriate proprietary drivers.

| improve this answer | |
  • My graphics card is radeon rx 570. I tried using the safe graphics option but it did the exact same thing. – nishantc1527 Jul 14 at 19:48
  • Have you tried adding radeon.modeset=0 to your kernel boot options (press 'e' when highlighting Ubuntu during boot to edit the options, find the line that says "linux" and change it)? Something else that you can do is to boot to the command line to confirm that the graphics are the issue, you can do that by putting a "3" as the last kernel boot option. – Giovanni Beltrame Jul 14 at 20:12
1

Some steps to check before installing from a liveUSB installer:

Enter your firmware and check/set the following options:

Fast boot : Disabled (this leaves initialization of a lot of devices to the installed OS often preventing booting a live environment other than DOS)

Secure boot : Disabled (Can also prevent booting from USB devices or anything else then the registered OS (windows 10))

CSM or Legacy mode or Both Legacy & UEFI : Disable any of those if you still want to use Windows 10 as well, use only UEFI mode.

Then retry to boot from the liveUSB and install Ubuntu

| improve this answer | |
  • I double checked all these, but it still isn't working. Thanks for the answer though. – nishantc1527 Jul 15 at 21:09
1

You can't install Ubuntu onto a USB stick which works on one system and automatically assume it will work on another system. If you had created a live USB stick you could assume it will boot on another system.

I'd suggest creating a regular Live USB stick and boot with that. For a trial run you can make a persistent Live USB stick instead of installing your Live USB to a USB stick.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.