0

As the title says, I cannot install anything from the Ubuntu Software Centre. After pressing the install button, the progress bar reaches 14% or sometime 100%, but then aborts and the following error messages displays:

Cannot install --application name-- Cannot perform the following tasks:

But no following tasks appear.

I have tried on several different applications with the same result. I have tried different commands for updating the Software Center (see Ubuntu Software Center Not Working? Here Are the Fixes - Make Tech Easier for details).

I found an earlier question that seemed to be about the same problem, but remained unsolved: Cannot install anything from Ubuntu software

I am running Ubuntu 18.04.4 LTS on a Dell XPS 13, updated from 16.04. I am not sure when the problem started, but with 16.04 it definitely worked.

EDIT: This is what I get when using the terminal:

joran@joran-laptop:~$ sudo apt install Matterhorn 
[sudo] password for joran:  
Reading package lists... Done
Building dependency tree        
Reading state information... Done
E: Unable to locate package Matterhorn

However, I also just tried to use the terminal to install klines, and that did work

2
  • Open a Terminal and type sudo apt install application-name (You pick the name of a piece of software you want) For example sudo apt install vlc. Then copy and past the results into a comment here or edit your question. The terminal will give you more clarity on what the error is. – walttheboss Jul 5 '20 at 22:12
  • Thanks @walttheboss, I did that and made an edit. Can you make anything out of this? – Joran Jul 6 '20 at 6:35
1

There is something called as a repository. The things you want to download (apps) are stored in this repository. These repositories have links to them. So when you say sudo apt install pkgname, your system searches for pkgname in all the repository links which you have added. But obviously not all the repositories are added to your system. So you need to add repository links to your system in order to be able to search in those repositories.

Eg, sudo apt install g++ will run just fine out of the box linux, as the link to the repository containing g++ is already added. But sudo apt install gimp won't work out of the box. For that you will need to add the gimp repository to your system with sudo add-apt-repository ppa:otto-kesselgulasch/gimp. After this you can run sudo apt update (this will update the repository links if needed) and then sudo apt install gimp to install gimp.

Similarly the repository link to Matterhorn might not be added to your system by default. Remember, it can only be added if its repository link exists. There are other ways to install Matterhron. You could try to install it with snap store. Just run sudo snap install matterhorn if snap is enabled on your system. If not then first run sudo apt update && sudo apt install snapd and then sudo snap install matterhorn. Visit here for more info.

You could try reinstalling the software-centre with sudo apt autoremove --purge gnome-software && sudo apt install gnome-software.

2
  • the op has posted links to many of the terminal comands that you have posted so one has to asume the op has tried atleast some of them. – trond hansen Jul 6 '20 at 8:18
  • Thank you @Abhay for explaining this and the useful link. I have not managed to get the Software center to work as I expect, but sudo snap install did the trick for most of the applications I needed. – Joran Jul 6 '20 at 22:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.