I think my gnome-panel is messed up because I alt+right click it and nothing pops up. I'm on 12.04, classic gnome desktop.

so I used locate and found gnome-panel in .gconf somewhere, how do I clear just gnome-panel's settings so that I can add things to my panel again?


matt: ~/.gconf $ find|grep -iw panel

5 Answers 5


Config reset

This worked for me in GNOME Classic on 12.04 to reset the gnome-panel configuration:

dconf reset -f /org/gnome/gnome-panel/
killall gnome-panel

Run the commands in a terminal or with Alt-F2.

Popup menu

Try Win-Alt-rightclick to get the popup menu.

  • 2
    Still works great with gnome-session-flashback. Apr 19, 2015 at 23:15

Open a terminal and paste:

gconftool-2 --recursive-unset /apps/panel


killall gnome-panel

Or you can manually delete the folder ~/.gconf/apps/panel/

mkdir ~/gnomepanelbackup ; mv ~/.gconf/apps/panel ~/gnomepanelbackup

this will create backup of current settings in home directory. then,

killall gnome-panel

Reference: 1.

  • hmm it looks the same ["show desktop" on left and "workspace switcher" on right], and I still cannot alt right-click and add to panel.
    – Matt
    Apr 27, 2012 at 0:37
  • Then you could try to manually delete the configuration folder ~/.gconf/apps/panel
    – desgua
    Apr 27, 2012 at 0:46
  • Ok that's the problem there is none, check the question again.
    – Matt
    Apr 27, 2012 at 12:54

I looked at other posts and tried:

gconftool-2 --shutdown
rm -rf ~/.gconf/apps/panel
pkill gnome-panel

It didn't work. But then I tried this, and bingo!

dconf reset -f /org/gnome/gnome-panel/
killall gnome-panel

I had a similar problem while transferim gnome-terminal settings from one machine to another.

My solution was copying related files and then kill gconfd-2 daemon

cp -r /tmp/backup/.gconf/apps/gnome-terminal/ ~/.gconf/apps/
killall gconfd-2

If you don't kill gconfd-2 changes aren't applied until you logout.


Should works with every desktop managers, gnome, mate, etc. Does not block the current shell.

killall $DESKTOP_SESSION-panel && $DESKTOP_SESSION-panel </dev/null >/dev/null 2>&1 &

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .